flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-3489) Refactor Table API before merging into master
Date Mon, 14 Mar 2016 15:11:33 GMT

    [ https://issues.apache.org/jira/browse/FLINK-3489?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15193456#comment-15193456

ASF GitHub Bot commented on FLINK-3489:

Github user twalthr commented on the pull request:

    @vasia I looked into the code again. You can remove the `typeInfo()` of `Expression` savely.
It is only used by `typeInfo()` of other expressions. Never executed.
    Regarding the `ExpressionException` maybe we keep it and rename it to `ExpressionParserException`
because it is only used by the `ExpressionParser` after removing `typeInfo()`.

> Refactor Table API before merging into master
> ---------------------------------------------
>                 Key: FLINK-3489
>                 URL: https://issues.apache.org/jira/browse/FLINK-3489
>             Project: Flink
>          Issue Type: Sub-task
>          Components: Table API
>            Reporter: Timo Walther
>            Assignee: Vasia Kalavri
> Before we merge the `tableOnCalcite` branch back into master, we should do some package/class
refactoring. Here are some ideas:
> - Move class {{TreeNode}} into {{expressions}} or its methods directly into {{Expression}}.
> - Remove the {{org.apache.flink.api.table.trees}} package.
> - Rename {{org.apache.flink.api.table.typeinfo}} to {{typeutils}} to be in sync with
other Flink modules.
> - Move {{TypeConverter}} to {{typeutils}}
> - Remove {{ExpressionException}} it is currently only used by {{typeInfo()}} of {{Expression}}
> - Remove {{typeInfo()}} of {{Expression}} and subclasses. It is not used.
> - Add {{ExecutionEnvironment}} as parameter of {{TableEnvironment}} (necessary for Table
API specific input formats) in order to not break the API in future?
> - Remove {{println}} in translators.
> Feel free to propose other changes.

This message was sent by Atlassian JIRA

View raw message