flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kostas (JIRA)" <j...@apache.org>
Subject [jira] [Assigned] (FLINK-3198) Rename Grouping.getDataSet() method and add JavaDocs
Date Mon, 25 Jan 2016 10:30:39 GMT

     [ https://issues.apache.org/jira/browse/FLINK-3198?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Kostas reassigned FLINK-3198:

    Assignee: Kostas

> Rename Grouping.getDataSet() method and add JavaDocs
> ----------------------------------------------------
>                 Key: FLINK-3198
>                 URL: https://issues.apache.org/jira/browse/FLINK-3198
>             Project: Flink
>          Issue Type: Improvement
>          Components: DataSet API
>    Affects Versions: 1.0.0, 0.10.1
>            Reporter: Fabian Hueske
>            Assignee: Kostas
>             Fix For: 1.0.0, 0.10.2
> The {{getDataSet()}} method of {{Grouping}} is public and visible to users. It returns
the input of the grouping operation which can cause confusion. If this function is used in
a regular DataSet program like this
> {code}
> DataSet<X> notGrouped = input.groupBy().getDataSet();
> DataSet<Y> allReduced = notGrouped.reduce()
> {code}
> the previous {{groupBy()}} call is basically discarded and an AllReduce is applied instead
of a grouped Reduce.
> Since this method is not meant to be part of the public API we should help users to avoid
this method. In the current API, we cannot easily change the visibility of the method without
package restructuring or adding additional classes (and hence breaking binary compatibility).
> Instead I proprose to rename the method to something like {{getInputDataSet()}} or {{getGroupingInput()}}
and add descriptive JavaDocs.

This message was sent by Atlassian JIRA

View raw message