flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Metzger (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-3115) Update Elasticsearch connector to 2.X
Date Fri, 04 Dec 2015 14:22:10 GMT

    [ https://issues.apache.org/jira/browse/FLINK-3115?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15041600#comment-15041600
] 

Robert Metzger commented on FLINK-3115:
---------------------------------------

I think we need to add a second module for the updated EL version for giving it different
dependencies.

> Update Elasticsearch connector to 2.X
> -------------------------------------
>
>                 Key: FLINK-3115
>                 URL: https://issues.apache.org/jira/browse/FLINK-3115
>             Project: Flink
>          Issue Type: Improvement
>          Components: Streaming Connectors
>    Affects Versions: 0.10.0, 1.0.0, 0.10.1
>            Reporter: Maximilian Michels
>             Fix For: 1.0.0
>
>
> The Elasticsearch connector is not up to date anymore. In version 2.X the API changed.
The code needs to be adapted. Probably it makes sense to have a new class {{ElasticsearchSink2}}.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message