flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mxm <...@git.apache.org>
Subject [GitHub] flink pull request: [FLINK-2797][cli] Add support for running jobs...
Date Thu, 22 Oct 2015 16:39:30 GMT
Github user mxm commented on a diff in the pull request:

    --- Diff: flink-clients/src/main/java/org/apache/flink/client/program/ContextEnvironment.java
    @@ -161,6 +171,8 @@ public ContextEnvironmentFactory(Client client, List<URL> jarFilesToAttach,
     			this.userCodeClassLoader = userCodeClassLoader;
     			this.defaultParallelism = defaultParallelism;
     			this.wait = wait;
    +			_plan = null;
    +			_graph = null;
    --- End diff --
    Is there a reason for these odd names? `lastBatchPlan` and `lastStreamJobGraph` would
be more appropriate. The first one is for batch programs, the latter for JobGraph created
by the streaming API.

If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.

View raw message