flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From hsaputra <...@git.apache.org>
Subject [GitHub] flink pull request: [FLINK-2386] Add new KafkaConsumer, based on K...
Date Fri, 21 Aug 2015 21:43:52 GMT
Github user hsaputra commented on a diff in the pull request:

    --- Diff: flink-core/src/main/java/org/apache/flink/util/NetUtils.java ---
    @@ -48,8 +48,9 @@ public static String getHostnameFromFQDN(String fqdn) {
     	 * Works also for ipv6.
     	 * See: http://stackoverflow.com/questions/2345063/java-common-way-to-validate-and-convert-hostport-to-inetsocketaddress
    +	 * @return URL object for accessing host and Port
    -	public static void ensureCorrectHostnamePort(String hostPort) {
    +	public static URL ensureCorrectHostnamePort(String hostPort) {
    --- End diff --
    Since it is now returning something, could we change the name to reflect it properly,
like ``generateCorrectUrlFromHostnameAndPort``

If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.

View raw message