flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthias J. Sax (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (FLINK-1658) Rename AbstractEvent to AbstractTaskEvent and AbstractJobEvent
Date Tue, 21 Jul 2015 12:03:05 GMT

    [ https://issues.apache.org/jira/browse/FLINK-1658?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14635006#comment-14635006
] 

Matthias J. Sax edited comment on FLINK-1658 at 7/21/15 12:02 PM:
------------------------------------------------------------------

I still see `org.apache.flink.runtime.event.job.AbstractEvent`. However, there is no sub-class
for it. I guess, it can be deleted.

However, there is:
  - `org.apache.flink.runtime.event.task.AbstractEvent`
  - `org.apache.flink.runtime.event.task.TaskEvent` (which is actually abstract)
  - `org.apache.flink.runtime.event.task.RuntimeEvent` (which is actually abstract)

Maybe, TaskEvent and RuntimeEvent should be renamed into AbstractTaskEvent and AbstractRuntimeEvent
?

However, I just discovered that TaskEvent wan introduced in d908ca19741bf2561cb6a7663541f642e60c0e6d
as a renaming of AbstractTaskEvent (for whatever reason an abstract class was renamed to not
start with "Abstract" ?)


was (Author: mjsax):
I still see `org.apache.flink.runtime.event.job.AbstractEvent`. However, there is no sub-class
for it. I guess, it can be deleted.

However, there is:
  - `org.apache.flink.runtime.event.task.AbstractEvent`
  - `org.apache.flink.runtime.event.task.TaskEvent` (which is actually abstract)
  - `org.apache.flink.runtime.event.task.RuntimeEvent` (which is actually abstract)

Maybe, TaskEvent and RuntimeEvent should be renamed into AbstractTaskEvent and AbstractRuntimeEvent
?

> Rename AbstractEvent to AbstractTaskEvent and AbstractJobEvent
> --------------------------------------------------------------
>
>                 Key: FLINK-1658
>                 URL: https://issues.apache.org/jira/browse/FLINK-1658
>             Project: Flink
>          Issue Type: Improvement
>          Components: Distributed Runtime, Local Runtime
>            Reporter: Gyula Fora
>            Priority: Trivial
>
> The same name is used for different event classes in the runtime which can cause confusion.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message