flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fabian Hueske (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (FLINK-2165) Rename Table conversion methods in TableEnvironment
Date Fri, 05 Jun 2015 13:46:00 GMT

     [ https://issues.apache.org/jira/browse/FLINK-2165?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Fabian Hueske closed FLINK-2165.
--------------------------------
    Resolution: Fixed

Fixed with 9b88184518c6f23f1a0f18d68623e4909b3c4476

> Rename Table conversion methods in TableEnvironment
> ---------------------------------------------------
>
>                 Key: FLINK-2165
>                 URL: https://issues.apache.org/jira/browse/FLINK-2165
>             Project: Flink
>          Issue Type: Improvement
>          Components: Table API
>    Affects Versions: 0.9
>            Reporter: Fabian Hueske
>            Assignee: Fabian Hueske
>            Priority: Minor
>             Fix For: 0.9
>
>
> The {{TableEnvironment}} provides methods to convert DataSets and DataStreams into Tables
and back. These methods are called {{toTable()}}, {{toSet()}}, and {{toStream()}}.
> I propose to rename the methods into {{fromDataSet()}}, {{fromDataStream()}}, {{toDataSet()}},
and {{toDataStream()}} for the following reasons:
> - {{fromDataSet()}}, {{fromDataStream()}} is closer to the SQL FROM expression
> - It allows to add methods such as {{fromCSV()}}, {{fromHCat()}}, {{fromParquet()}},
and so on to the {{TableEnvironment}}
> - {{toSet()}} and {{toStream()}} should be renamed for consistency.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message