flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-2165) Rename Table conversion methods in TableEnvironment
Date Fri, 05 Jun 2015 10:19:00 GMT

    [ https://issues.apache.org/jira/browse/FLINK-2165?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14574267#comment-14574267

ASF GitHub Bot commented on FLINK-2165:

GitHub user fhueske opened a pull request:


    [FLINK-2165] [TableAPI] Renamed table conversion functions in TableEnvironment


You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/fhueske/flink fromDataSet

Alternatively you can review and apply these changes as the patch at:


To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #793
commit 9dd5ca596282786c0ae4e2b104e4f36de48554f6
Author: Fabian Hueske <fhueske@apache.org>
Date:   2015-06-05T09:37:39Z

    [FLINK-2165] [TableAPI] Renamed table conversion functions in TableEnvironment


> Rename Table conversion methods in TableEnvironment
> ---------------------------------------------------
>                 Key: FLINK-2165
>                 URL: https://issues.apache.org/jira/browse/FLINK-2165
>             Project: Flink
>          Issue Type: Improvement
>          Components: Table API
>    Affects Versions: 0.9
>            Reporter: Fabian Hueske
>            Assignee: Fabian Hueske
>            Priority: Minor
>             Fix For: 0.9
> The {{TableEnvironment}} provides methods to convert DataSets and DataStreams into Tables
and back. These methods are called {{toTable()}}, {{toSet()}}, and {{toStream()}}.
> I propose to rename the methods into {{fromDataSet()}}, {{fromDataStream()}}, {{toDataSet()}},
and {{toDataStream()}} for the following reasons:
> - {{fromDataSet()}}, {{fromDataStream()}} is closer to the SQL FROM expression
> - It allows to add methods such as {{fromCSV()}}, {{fromHCat()}}, {{fromParquet()}},
and so on to the {{TableEnvironment}}
> - {{toSet()}} and {{toStream()}} should be renamed for consistency.

This message was sent by Atlassian JIRA

View raw message