flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefan Bunk (JIRA)" <j...@apache.org>
Subject [jira] [Created] (FLINK-1890) Add withReadFields or sth. similar to Scala API
Date Tue, 14 Apr 2015 18:04:12 GMT
Stefan Bunk created FLINK-1890:

             Summary: Add withReadFields or sth. similar to Scala API
                 Key: FLINK-1890
                 URL: https://issues.apache.org/jira/browse/FLINK-1890
             Project: Flink
          Issue Type: Wish
          Components: Java API, Scala API
            Reporter: Stefan Bunk
            Priority: Minor

In the Scala API, you have the option to declare forwarded fields via the
{{withForwardedFields}} method.
It would be nice to have sth. similar for read fields, as otherwise one needs to create a
class, which I personally try to avoid for readability.

Maybe grouping all annotations in one function and have a first parameter indicating the type
of annotation is also an option, if you plan on adding more annotations and want to keep the
interface smaller.

This message was sent by Atlassian JIRA

View raw message