flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefan Bunk (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-1890) Add withReadFields or sth. similar to Scala API
Date Tue, 21 Apr 2015 10:45:58 GMT

    [ https://issues.apache.org/jira/browse/FLINK-1890?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14504756#comment-14504756

Stefan Bunk commented on FLINK-1890:

Ok, didn't know that.
In that case, imho, I would prefer it to not occur in the docs. After all, I spend some time
looking into that feature, thinking about how to how to integrate it in my code, all for a
feature which may never be implemented.
At least a warning in the docs would be nice.

> Add withReadFields or sth. similar to Scala API
> -----------------------------------------------
>                 Key: FLINK-1890
>                 URL: https://issues.apache.org/jira/browse/FLINK-1890
>             Project: Flink
>          Issue Type: Wish
>          Components: Java API, Scala API
>            Reporter: Stefan Bunk
>            Priority: Minor
> In the Scala API, you have the option to declare forwarded fields via the
> {{withForwardedFields}} method.
> It would be nice to have sth. similar for read fields, as otherwise one needs to create
a class, which I personally try to avoid for readability.
> Maybe grouping all annotations in one function and have a first parameter indicating
the type of annotation is also an option, if you plan on adding more annotations and want
to keep the interface smaller.

This message was sent by Atlassian JIRA

View raw message