flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Suneel Marthi (JIRA)" <j...@apache.org>
Subject [jira] [Assigned] (FLINK-1780) Rename FlatCombineFunction to GroupCombineFunction
Date Tue, 24 Mar 2015 19:15:53 GMT

     [ https://issues.apache.org/jira/browse/FLINK-1780?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Suneel Marthi reassigned FLINK-1780:
------------------------------------

    Assignee: Suneel Marthi

> Rename FlatCombineFunction to GroupCombineFunction
> --------------------------------------------------
>
>                 Key: FLINK-1780
>                 URL: https://issues.apache.org/jira/browse/FLINK-1780
>             Project: Flink
>          Issue Type: Improvement
>          Components: Java API, Scala API
>    Affects Versions: 0.9
>            Reporter: Fabian Hueske
>            Assignee: Suneel Marthi
>            Priority: Minor
>              Labels: starter
>             Fix For: 0.9
>
>
> The recently added {{GroupCombineOperator}} requires a {{FlatCombineFunction}}, however
a {{GroupReduceOperator}} requires a {{GroupReduceFunction}}. {{FlatCombineFunction}} and
{{GroupReduceFunction}} work on the same types of parameters (Iterable and Collector).
> Therefore, I propose to change the name {{FlatCombineFunction}} to {{GroupCombineFunction}}.
Since the function could not be independently used until recently, this API breaking change
should be OK.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message