flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-1622) Add GroupReducePartial Operator
Date Fri, 13 Mar 2015 16:22:38 GMT

    [ https://issues.apache.org/jira/browse/FLINK-1622?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14360573#comment-14360573

ASF GitHub Bot commented on FLINK-1622:

Github user mxm commented on the pull request:

    @aljoscha @fhueske @hsaputra Thanks for the feedback. Some people suggested that the name
is confusing and that my pull request involved too much code duplication. I propose to call
the new operator `combineGroup` because it is a combiner that works on Groups, just like the
existing combiners in `GroupReduceCombineDriver` and `AllGroupReduceDriver`. I refactored
the code to reuse Flink's existing logic for combiners. 
    @hsaputra I added documentation for the operator in the code and the official documentation.
Some Scala tests for the API were added as well.
    When merging this pull request, I would squash the two commits and keep the commit message
of the latest one. I simply wanted to keep the first one to show the development process.

> Add GroupReducePartial Operator
> -------------------------------
>                 Key: FLINK-1622
>                 URL: https://issues.apache.org/jira/browse/FLINK-1622
>             Project: Flink
>          Issue Type: Sub-task
>    Affects Versions: 0.9
>            Reporter: Aljoscha Krettek
> This does what a Reduce or GroupReduce Operator does, except it is only performed on
a local partition.
> This is also similar to an explicit combine that can output a type that is different
from the input.

This message was sent by Atlassian JIRA

View raw message