flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ufuk Celebi (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-1034) Inconsistent naming of DataSet reduceGroup and GroupReduceFunction
Date Sat, 26 Jul 2014 18:08:38 GMT

    [ https://issues.apache.org/jira/browse/FLINK-1034?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14075451#comment-14075451
] 

Ufuk Celebi commented on FLINK-1034:
------------------------------------

Thanks for the explanation [~ktzoumas]. I didn't think about it like that before. ;-)

We also had an offline discussion with [~StephanEwen] and the argument he made was that we
shouldn't change the API as syntactic sugar.

Another option would be to deprecate {{DataSet.reduceGroup}} and overload {{DataSet.reduce}}.
This would also be in line with the overriden reduce method in both {{GroupReduceFunction}}
and {{ReduceFunction}}.

I am very unemotional ;-) about this and don't want to discuss it to death, but would appreciate
short feedback to the last suggestion with the overloaded reduce.

> Inconsistent naming of DataSet reduceGroup and GroupReduceFunction
> ------------------------------------------------------------------
>
>                 Key: FLINK-1034
>                 URL: https://issues.apache.org/jira/browse/FLINK-1034
>             Project: Flink
>          Issue Type: Improvement
>          Components: Java API
>            Reporter: Ufuk Celebi
>            Priority: Trivial
>              Labels: breaking-api
>
> I don't know if it is on purpose or not, but I found it to be inconsistent and sometimes
also confusing:
> Why not
> {code:java}
> input.groupReduce(new GroupReduceFunction() {...})
> {code}
> instead of the current
> {code:java}
> input.reduceGroup(new GroupReduceFunction() {...})
> {code}
> I think it's the same line of thinking, which results in overriding a {{reduce}} method
in {{GroupReduceFunction}} instead of a {{groupReduce}} method.
> Is there a nice way to unify this?



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message