flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ufuk Celebi (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (FLINK-1034) Inconsistent naming of DataSet reduceGroup and GroupReduceFunction
Date Thu, 24 Jul 2014 10:17:38 GMT

     [ https://issues.apache.org/jira/browse/FLINK-1034?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ufuk Celebi updated FLINK-1034:
-------------------------------

    Labels: breaking-api  (was: )

> Inconsistent naming of DataSet reduceGroup and GroupReduceFunction
> ------------------------------------------------------------------
>
>                 Key: FLINK-1034
>                 URL: https://issues.apache.org/jira/browse/FLINK-1034
>             Project: Flink
>          Issue Type: Improvement
>          Components: Java API
>            Reporter: Ufuk Celebi
>            Priority: Trivial
>              Labels: breaking-api
>
> I don't know if it is on purpose or not, but I found it to be inconsistent and sometimes
also confusing:
> Why not
> {code:java}
> input.groupReduce(new GroupReduceFunction() {...})
> {code}
> instead of the current
> {code:java}
> input.reduceGroup(new GroupReduceFunction() {...})
> {code}
> I think it's the same line of thinking, which results in overriding a {{reduce}} method
in {{GroupReduceFunction}} instead of a {{groupReduce}} method.
> Is there a nice way to unify this?



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message