flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Warneke (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-1010) Conflicting Scala Versions
Date Tue, 08 Jul 2014 18:39:04 GMT

    [ https://issues.apache.org/jira/browse/FLINK-1010?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14055273#comment-14055273
] 

Daniel Warneke commented on FLINK-1010:
---------------------------------------

I fixed this already as part of FLINK-386 which is subject to be merged.

> Conflicting Scala Versions
> --------------------------
>
>                 Key: FLINK-1010
>                 URL: https://issues.apache.org/jira/browse/FLINK-1010
>             Project: Flink
>          Issue Type: Bug
>          Components: Build System
>    Affects Versions: 0.6-incubating
>            Reporter: Stephan Ewen
>            Assignee: Till Rohrmann
>             Fix For: 0.6-incubating
>
>
> I am seeing the following error. Can we simply set the Scala Version for everything to
2.10.4?
> {code}
> [WARNING]  Expected all dependencies to require Scala version: 2.10.3
> [WARNING]  org.scala-lang:scala-reflect:2.10.3 requires scala version: 2.10.3
> [WARNING]  eu.stratosphere:stratosphere-scala:0.6-SNAPSHOT requires scala version: 2.10.3
> [WARNING]  eu.stratosphere:stratosphere-scala:0.6-SNAPSHOT requires scala version: 2.10.3
> [WARNING]  org.scala-lang:scala-compiler:2.10.3 requires scala version: 2.10.3
> [WARNING]  org.scalatest:scalatest_2.10:2.2.0 requires scala version: 2.10.4
> [WARNING] Multiple versions of scala libraries detected!
> {code}



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message