flink-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Metzger <rmetz...@apache.org>
Subject Re: [DISCUSS] Stop serving docs for Flink version prior to 1.0
Date Tue, 22 Aug 2017 16:07:06 GMT
Please go ahead +1

Thank you for taking care!

On Tue, Aug 22, 2017 at 6:02 PM, Aljoscha Krettek <aljoscha@apache.org>
wrote:

> +1
> > On 22. Aug 2017, at 18:01, Stephan Ewen <sewen@apache.org> wrote:
> >
> > +1
> >
> > On Tue, Aug 22, 2017 at 5:58 PM, Ufuk Celebi <uce@apache.org> wrote:
> >
> >> Quick update: If there are no objections, I will start looking into
> >> how to stop serving the docs for Flink < 1.0 after tomorrow.
> >>
> >>
> >> On Wed, Aug 16, 2017 at 10:45 PM, Ufuk Celebi <uce@apache.org> wrote:
> >>> Thanks for your early feedback Kostas and Ted.
> >>>
> >>> @Kostas: I have a proposal for a more obvious warning here:
> >>> https://github.com/apache/flink/pull/4553 Would appreciate comments in
> >>> that PR too :-)
> >>>
> >>>
> >>> On Wed, Aug 16, 2017 at 6:56 PM, Ted Yu <yuzhihong@gmail.com> wrote:
> >>>> Without any upgrade path, the old versions are not useful.
> >>>>
> >>>> +1 on redirecting doc to stable release(s).
> >>>>
> >>>> On Wed, Aug 16, 2017 at 9:46 AM, Kostas Kloudas <
> >> k.kloudas@data-artisans.com
> >>>>> wrote:
> >>>>
> >>>>> Hi Ufuk,
> >>>>>
> >>>>> +1
> >>>>>
> >>>>> I think that this is a nice change!
> >>>>> Thanks Ufuk for opening the discussion.
> >>>>>
> >>>>> I think that broken/redirect links are not an issue,
> >>>>> as either way the information provided is far outdated
> >>>>> (== wrong).
> >>>>>
> >>>>> As for the warning, we cannot put it in the header instead
> >>>>> of the footer? Sth like, this page may contain outdated info,
> >>>>> please refer to XXX for an updated version.
> >>>>>
> >>>>> Kostas
> >>>>>
> >>>>>> On Aug 16, 2017, at 6:02 PM, Ufuk Celebi <uce@apache.org>
wrote:
> >>>>>>
> >>>>>> Hey devs,
> >>>>>>
> >>>>>> I would like to stop serving the documentation for all Flink
> versions
> >>>>>> prior to 1.0.
> >>>>>>
> >>>>>> Do you have any concerns about this?
> >>>>>>
> >>>>>> These Flink versions are very old without any upgrade path to
newer
> >>>>>> versions but they still get a lot of traffic and most new users
> don't
> >>>>>> realize that they are looking at a very outdated docs page.
> >>>>>>
> >>>>>> Even with a stronger warning about being outdated, I don't see
a
> >> point
> >>>>>> in serving them.
> >>>>>>
> >>>>>> If we choose to do this, I would redirect these ancient pages
to the
> >>>>>> docs of the latest stable release and update the release process
> Wiki
> >>>>>> page to update those redirects etc.
> >>>>>>
> >>>>>> This will mean that some links in old StackOverflow questions
and
> the
> >>>>>> mailing list archives will be broken/redirected. If you have
> concerns
> >>>>>> about this, please raise your voice in this thread.
> >>>>>>
> >>>>>> – Ufuk
> >>>>>>
> >>>>>> PS: I've created an issue to improve the visibility of the outdated
> >>>>>> warning here https://issues.apache.org/jira/browse/FLINK-7462.
I
> >> will
> >>>>>> only apply this to versions >= 1.0 for now.
> >>>>>
> >>>>>
> >>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message