flink-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject Re: Supported Hadoop versions
Date Sun, 30 Apr 2017 14:46:12 GMT
For #1, +1 on dropping hadoop 1.

For #2, we can reference Hadoop 2.7
BTW I think we can bump to 2.7.3 as dependency.

For #3, Hadoop 2.8.0 was marked not production ready. Junping is in the
process of releasing 2.8.1
It would be good idea to start testing against 2.8.0 now

Cheers

On Sun, Apr 30, 2017 at 4:16 AM, Greg Hogan <code@greghogan.com> wrote:

> Hi Flink,
>
> I filed a ticket [0] that our download page [1] still states
>
> “You don’t have to install Hadoop to use Flink, but if you plan to use
> Flink with data stored in Hadoop, pick the version matching your installed
> Hadoop version. If you don’t want to do this, pick the Hadoop 1 version.”
>
> 1) We no longer offer the Hadoop 1 version, which I expect was chosen due
> to its smaller size. What is the new recommendation?
>
> 2) Should we reference, for example, “Hadoop 2.7” (as with the binary
> filenames) rather than “Hadoop 2.7.0” since we are actually testing and
> releasing against Hadoop 2.7.2?
>
> 3) Should Flink 1.3.0 support the recently released Hadoop 2.8.0? Is this
> the time to drop older versions (which users can easily build)? This would
> also be the time to bump the patch versions in .travis.yml and
> create-release-files.sh.
>
> I ask because I think it is important to present this choice well since it
> is likely to be a new users first decision point.
>
> [0] https://issues.apache.org/jira/browse/FLINK-6399 <
> https://issues.apache.org/jira/browse/FLINK-6399>
> [1] https://flink.apache.org/downloads.html <https://flink.apache.org/
> downloads.html>
>
> Greg

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message