flink-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Till Rohrmann (JIRA)" <j...@apache.org>
Subject [jira] [Created] (FLINK-5297) Relocate Flink's Hadoop dependency and its transitive dependencies
Date Thu, 08 Dec 2016 16:50:58 GMT
Till Rohrmann created FLINK-5297:
------------------------------------

             Summary: Relocate Flink's Hadoop dependency and its transitive dependencies
                 Key: FLINK-5297
                 URL: https://issues.apache.org/jira/browse/FLINK-5297
             Project: Flink
          Issue Type: Improvement
          Components: Build System
    Affects Versions: 1.2.0
            Reporter: Till Rohrmann
             Fix For: 1.2.0


A user reported that they have a dependency conflict with one of Hadoop's dependencies. More
concretely it is the {{aws-java-sdk-*}} dependency which is not backward compatible. The user
is dependent on a newer {{aws-java-sdk}} version which cannot be used by Hadoop version 2.7.

A solution for future dependency conflicts could be to relocate Hadoop's dependencies or even
all of the Hadoop dependency.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message