flink-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Maximilian Michels (JIRA)" <j...@apache.org>
Subject [jira] [Created] (FLINK-5262) Docs: Introduce a Gemfile.lock to avoid dependency range conflicts
Date Mon, 05 Dec 2016 13:48:58 GMT
Maximilian Michels created FLINK-5262:
-----------------------------------------

             Summary: Docs: Introduce a Gemfile.lock to avoid dependency range conflicts
                 Key: FLINK-5262
                 URL: https://issues.apache.org/jira/browse/FLINK-5262
             Project: Flink
          Issue Type: Bug
          Components: Documentation
            Reporter: Maximilian Michels
            Assignee: Maximilian Michels


The {{Gemfile}} for specifying the Ruby dependencies of our documentation has fixed dependency
versions to avoid incompatible changes with different versions of the dependencies. However,
Ruby's dependency management allows artifacts to specify ranges for dependencies. This can
be problematic. 

For instance, we use 'jekyll' version 2.5.3 which depends on 'jekyll-gist' ~> 1.0 which
means 1.0 >= version < 2.0. This may resolve 'jekyll-gist' 1.4.0 which depends on 'octokit'
~> 4.2 which may be 4.2 >= versions < 5.0. Too bad, 'octokit' 4.4. depends on Ruby
version >= 2.0 which is not available on our build servers.

Since we already use the improved version of Rubys build system called 'bundler', we can mitigate
this problem by checking in a {{Gemfile.lock}} file which specifies the exact versions of
all dependencies required to build the docs.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message