flink-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aljoscha Krettek <aljos...@apache.org>
Subject Re: trouble using maven to deploy master branch to a private repo
Date Mon, 12 Dec 2016 15:01:32 GMT
Hi Steve,
I think this part of create_release_files.sh (our release script) is
helpful:

mvn clean deploy -Prelease,docs-and-source --settings deploysettings.xml
-DskipTests -Dgpg.executable=$GPG -Dgpg.keyname=$GPG_KEY
-Dgpg.passphrase=$GPG_PASSPHRASE -DretryFailedDeploymentCount=10

I think -Prelease could be what is needed for your case (if all the
repository settings for your local environment are already there).

I'm no expert on maven and releases but please let me know if you need more
help, then I could try and ping someone who knows more about this.

Cheers,
Aljoscha

On Wed, 7 Dec 2016 at 20:03 sblackmon <sblackmon@apache.org> wrote:

> Hello,
>
> At People Pattern we’ve been using flink 1.x releases in production since
> June 2016.
>
> We’re now at the point where we want to incorporate some of the bleeding
> edge features before official releases.
>
> I’ve forked flink from master, done a build on my local environment, then
> built flink-dist, built our pipelines against 1.2-SNAPSHOT, and
> successfully run them using 1.2-SNAPSHOT on EMR YARN.  Great.
>
> Now I want to give the rest of my team access to pre-release flink
> snapshots using maven, without needing to build flink themselves.
>
> My typical strategy to do something like this would be to build a
> minimally modified fork on our private jenkins, deployed to our private
> maven.
>
>         mvn clean install deploy -DskipTests -Drat.skip=true
> -Dhadoop.version=2.7.3
>
> Deployments are happening, BUT, I get the error below (both on jenkins and
> locally) when the ‘deploy’ goal is activated.
>
> My hunch is that some profile contains some special sauce that needs to be
> present during official / unofficial deployments, or maybe I’m missing some
> maven flags.
>
> If anyone knows which profiles / flags I might be missing, I’d love to
> know.  Or if anyone is able to reproduce, and/or let me know why it is or
> isn’t actually a problem, that would be great too.
>
> Thanks in advance,
> Steve
>
> —
>
> [INFO] --- maven-assembly-plugin:2.4:single (create-test-dependency) @
> flink-clients_2.10 ---
> [INFO] Reading assembly descriptor: src/test/assembly/test-assembly.xml
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Reactor Summary:
> [INFO]
> [INFO] force-shading ...................................... SUCCESS [
>  5.259 s]
> [INFO] flink .............................................. SUCCESS [
>  4.350 s]
> [INFO] flink-annotations .................................. SUCCESS [
> 11.695 s]
> [INFO] flink-shaded-hadoop ................................ SUCCESS [
>  2.674 s]
> [INFO] flink-shaded-hadoop2 ............................... SUCCESS [
> 29.174 s]
> [INFO] flink-shaded-curator ............................... SUCCESS [
>  2.328 s]
> [INFO] flink-shaded-curator-recipes ....................... SUCCESS [
>  8.986 s]
> [INFO] flink-shaded-curator-test .......................... SUCCESS [
>  6.531 s]
> [INFO] flink-metrics ...................................... SUCCESS [
>  2.791 s]
> [INFO] flink-metrics-core ................................. SUCCESS [
> 14.614 s]
> [INFO] flink-test-utils-parent ............................ SUCCESS [
>  2.528 s]
> [INFO] flink-test-utils-junit ............................. SUCCESS [
> 12.415 s]
> [INFO] flink-core ......................................... SUCCESS [
> 56.806 s]
> [INFO] flink-java ......................................... SUCCESS [
> 38.498 s]
> [INFO] flink-runtime ...................................... SUCCESS [01:52
> min]
> [INFO] flink-optimizer .................................... SUCCESS [
> 30.665 s]
> [INFO] flink-clients ...................................... FAILURE [
>  4.158 s]
> …
> [ERROR] Failed to execute goal
> org.apache.maven.plugins:maven-assembly-plugin:2.4:single
> (create-test-dependency) on project flink-clients_2.10: Error reading
> assemblies: Error locating assembly descriptor:
> src/test/assembly/test-assembly.xml
> [ERROR]
> [ERROR] [1] [INFO] Searching for file location:
> /Users/sblackmon/Dropbox/git/flink/flink-clients/target/src/test/assembly/test-assembly.xml
> [ERROR]
> [ERROR] [2] [INFO] File:
> /Users/sblackmon/Dropbox/git/flink/flink-clients/target/src/test/assembly/test-assembly.xml
> does not exist.
> [ERROR]
> [ERROR] [3] [INFO] File:
> /Users/sblackmon/Dropbox/git/flink/src/test/assembly/test-assembly.xml does
> not exist.
> [ERROR] -> [Help 1]
> [ERROR]
> [ERROR] To see the full stack trace of the errors, re-run Maven with the
> -e switch.
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> [ERROR]
> [ERROR] For more information about the errors and possible solutions,
> please read the following articles:
> [ERROR] [Help 1]
> http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
> [ERROR]
> [ERROR] After correcting the problems, you can resume the build with the
> command
> [ERROR]   mvn <goals> -rf :flink-clients_2.10
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message