flink-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Till Rohrmann <trohrm...@apache.org>
Subject Re: Issue deploying a topology to flink with a java api
Date Wed, 13 Apr 2016 12:57:27 GMT
I've updated the master. Could you check it out and run your program with
the latest master? I would expect to see a ClassNotFoundException.

On Wed, Apr 13, 2016 at 2:54 PM, Till Rohrmann <trohrmann@apache.org> wrote:

> Yes that is true. I'll commit a hotfix for that.
>
> My suspicion is that we use the wrong class loader in the
> FlinkTopology.copyObject method to load the RandomSentenceSpout class. We
> can see that once I removed the exception swallowing in the current master.
>
> On Wed, Apr 13, 2016 at 2:40 PM, star jlong <jlongstar@yahoo.fr.invalid>
> wrote:
>
>> Hi Schepler,
>>
>> Thanks for the concerned. Yes I'm actaully having the same issue as
>> indicated on that post because I'm the one that posted that issue.
>>
>>     Le Mercredi 13 avril 2016 13h35, Chesnay Schepler <chesnay@apache.org>
>> a écrit :
>>
>>
>>
>> http://stackoverflow.com/questions/36584784/issues-while-submitting-a-topology-to-apache-flink-using-the-flink-api
>>
>> On 13.04.2016 14:28, Till Rohrmann wrote:
>> > Hi jstar,
>> >
>> > what's exactly the problem you're observing?
>> >
>> > Cheers,
>> > Till
>> >
>> > On Wed, Apr 13, 2016 at 2:23 PM, star jlong <jlongstar@yahoo.fr.invalid
>> >
>> > wrote:
>> >
>> >> Hi there,
>> >>
>> >> I'm jstar. I have been playing around with flink. I'm very much
>> interested
>> >> in submitting a topoloy  to flink using its api. As indicated
>> >> on stackoverflow, that is the try that I have given. But I was stuck
>> with
>> >> some exception. Please any help will be welcoming.
>> >>
>> >>
>> >> Thanks.
>> >> jstar
>>
>>
>>
>>
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message