flink-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chiwan Park <chiwanp...@icloud.com>
Subject Re: Error when building the docs
Date Fri, 06 Nov 2015 03:33:04 GMT
Hi Martin,

I had the same problem. From my investigation, current custom Jekyll plugin for Flink is not
compatible with Jekyll 3.x. If you remove Jekyll 3.x and install Jekyll 2.x, you can build
docs. I’m using Jekyll 2.5.3 to build the docs.

Regards,
Chiwan Park


On November 6, 2015 at 4:58:34 AM, Martin Junghanns (m.junghanns@mailbox.org) wrote:

Hi, not sure if that's an issue or just a misconfiguration (not familiar  
with Ruby).  

I followed the docs/README.md and ran into:  

s1ck@s1ck-T450s:~/Devel/Java/flink$ docs/build_docs.sh  
Configuration file: /home/s1ck/Devel/Java/flink/docs/_config.yml  
/home/s1ck/Devel/Java/flink/docs/_plugins/removeDuplicateLicenseHeaders.rb:63:in  
`<module:Jekyll>': cannot load such file -- jekyll/post (LoadError)  
from  
/home/s1ck/Devel/Java/flink/docs/_plugins/removeDuplicateLicenseHeaders.rb:25:in  
`<top (required)>'  

When I delete removeDuplicateLicenseHeaders.rb from the _plugins folder  
everything runs fine.  

I am using:  
3.19.0-32-generic #37-Ubuntu x86_64 x86_64 x86_64 GNU/Linux  
ruby 2.1.2p95 (2014-05-08) [x86_64-linux-gnu]  
jekyll (3.0.0)  
kramdown (1.9.0)  
pygments.rb (0.6.3) // wasn't part of the README but needs to be there  

Cheers,  
Martin  

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message