flink-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Metzger (JIRA)" <j...@apache.org>
Subject [jira] [Created] (FLINK-2581) Add warning to the YARN client when using an older Hadoop version
Date Thu, 27 Aug 2015 09:30:45 GMT
Robert Metzger created FLINK-2581:
-------------------------------------

             Summary: Add warning to the YARN client when using an older Hadoop version
                 Key: FLINK-2581
                 URL: https://issues.apache.org/jira/browse/FLINK-2581
             Project: Flink
          Issue Type: Improvement
          Components: YARN Client
    Affects Versions: 0.10
            Reporter: Robert Metzger
            Assignee: Robert Metzger


Some users were facing issues when using Flink on YARN because they were using outdated Hadoop
releases included into Flink.

In this example, the user was using Flink with hadoop 2.2.0 included, against a Hadoop 2.6.0
cluster: http://stackoverflow.com/questions/32085990/error-with-kerberos-authentication-when-executing-flink-example-code-on-yarn-clu/32131571

With this change, I'm going to ResourceManager's REST API to get the Hadoop version of the
remote YARN cluster: http://hadoop.apache.org/docs/r2.4.1/hadoop-yarn/hadoop-yarn-site/ResourceManagerRest.html
This Hadoop class allows us to determine the local Hadoop version we are using: https://hadoop.apache.org/docs/r1.2.1/api/org/apache/hadoop/util/VersionInfo.html



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message