flink-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephan Ewen <se...@apache.org>
Subject Re: Builds Problems on Travis
Date Thu, 13 Aug 2015 15:11:44 GMT
That is a shading problem.

Are you including Guava in your dependencies, or are you only
"transitively" referring to it?

Have a look here:
https://cwiki.apache.org/confluence/display/FLINK/Hadoop+Versions+and+Dependency+Shading

On Thu, Aug 13, 2015 at 2:19 PM, Matthias J. Sax <
mjsax@informatik.hu-berlin.de> wrote:

> Hi,
>
> I encountered a strange build problem in one of my branches. I have no
> idea what the problem might be. Did I break anything? The current master
> does not seem to have this problem.
>
> The Error is as follows:
>
> > ERROR]
> /home/travis/build/mjsax/flink/flink-contrib/flink-storm-compatibility/flink-storm-compatibility-core/src/main/java/org/apache/flink/stormcompatibility/wrappers/StormFiniteSpoutWrapper.java:[27,64]
> package org.apache.flink.hadoop.shaded.com.google.common.collect does not
> exist
>
> https://travis-ci.org/apache/flink/builds/75408468
> https://travis-ci.org/mjsax/flink/builds/75408462
> https://travis-ci.org/apache/flink/builds/75396233
> https://travis-ci.org/mjsax/flink/builds/75395715
>
> Any ideas?
>
>
> -Matthias
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message