flink-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephan Ewen <se...@apache.org>
Subject Re: [DISCUSS] Inconsistent naming of intermediate results
Date Thu, 04 Jun 2015 17:31:14 GMT
I am in principle with Ufuk on that, but let's not rush this into the
release. It is not a public API after all.

On Thu, Jun 4, 2015 at 5:23 PM, Ufuk Celebi <uce@apache.org> wrote:

> On 04 Jun 2015, at 17:02, Maximilian Michels <mxm@apache.org> wrote:
> > I think ResultPartition is a pretty accurate description of what it is: a
> > partition of the result of an operator. ResultStream on the other hand,
> > seems very generic to me. Just because we like to think of Flink nowadays
> > as a "streaming data flow" engine, we don't have to change the core
> > classes' names :)
> Of course, we don't have to. ;-) But still, I think it makes sense for
> documentation and blog post purposes. The code is new, it's not like
> changing a old component, on which a lot of stuff depends AND we want to
> change the name anyways (see your comments in this thread).

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message