flink-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aljoscha Krettek <aljos...@apache.org>
Subject About Operator and OperatorBase
Date Wed, 15 Apr 2015 12:11:07 GMT
This is just a personal annoyance and I think we are to advanced to
change this now, but here goes: Could we rename the classes in the
API, so that for example MapOperator becomes MapDataSet or MapSet, and
the actual operators in the common package become MapOperator instead
of MapOperatorBase.

My thinking is that two things called MapOperator are very confusing.
If we want to change this we should do it fast.


View raw message