flink-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephan Ewen <se...@apache.org>
Subject Re: About Operator and OperatorBase
Date Wed, 15 Apr 2015 13:01:36 GMT
I think we can rename the base operators.

Renaming the subclass of DataSet would be extremely api breaking. I think
that is not worth it.
Am 15.04.2015 14:11 schrieb "Aljoscha Krettek" <aljoscha@apache.org>:

> This is just a personal annoyance and I think we are to advanced to
> change this now, but here goes: Could we rename the classes in the
> API, so that for example MapOperator becomes MapDataSet or MapSet, and
> the actual operators in the common package become MapOperator instead
> of MapOperatorBase.
> My thinking is that two things called MapOperator are very confusing.
> If we want to change this we should do it fast.
> Cheers,
> Aljoscha

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message