flink-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fabian Hueske <fhue...@gmail.com>
Subject Re: About Operator and OperatorBase
Date Thu, 16 Apr 2015 13:16:45 GMT
Renaming the core operators is fine with me, but I would not touch API
facing classes.
A big +1 for Timo's suggestion.

2015-04-16 6:30 GMT-05:00 Timo Walther <twalthr@apache.org>:

> I share Stephans opinion.
>
> By the way, we could also find a common name for operators with two
> inputs. Sometimes it's "TwoInputXXX", "DualInputXXX", "BinaryInputXXX"...
> pretty inconsistent.
>
>
> On 15.04.2015 17:48, Till Rohrmann wrote:
>
>> I would also be in favour of making the distinction between the API and
>> common API layer more clear by using different names. This will ease the
>> understanding of the source code.
>>
>> In the wake of a possible renaming we could also get rid of the legacy
>> code
>> org.apache.flink.optimizer.dag.MatchNode and
>> rename org.apache.flink.runtime.operators.MatchDriver into JoinDriver to
>> make the naming more consistent.
>>
>> On Wed, Apr 15, 2015 at 3:05 PM, Ufuk Celebi <uce@apache.org> wrote:
>>
>>  On 15 Apr 2015, at 15:01, Stephan Ewen <sewen@apache.org> wrote:
>>>
>>>  I think we can rename the base operators.
>>>>
>>>> Renaming the subclass of DataSet would be extremely api breaking. I
>>>> think
>>>> that is not worth it.
>>>>
>>> Oh, that's right. We return MapOperator for DataSet operations. Stephan's
>>> point makes sense.
>>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message