flink-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ufuk Celebi <...@apache.org>
Subject Re: About Operator and OperatorBase
Date Wed, 15 Apr 2015 13:00:30 GMT

On 15 Apr 2015, at 14:11, Aljoscha Krettek <aljoscha@apache.org> wrote:

> This is just a personal annoyance and I think we are to advanced to
> change this now, but here goes: Could we rename the classes in the
> API, so that for example MapOperator becomes MapDataSet or MapSet, and
> the actual operators in the common package become MapOperator instead
> of MapOperatorBase.
> My thinking is that two things called MapOperator are very confusing.
> If we want to change this we should do it fast.


Realistically speaking, no one except the core committers are working on the internals currently.
Better change it now (or never :D).
View raw message