flink-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephan Ewen <se...@apache.org>
Subject Re: Problem mvn install
Date Mon, 02 Mar 2015 17:32:03 GMT
We have not excluded the "bin" directory by default, because the flink bin
directory (flink-dist/src/main/flink-bin/ with the bash scripts) should be
checked by RAT for valid headers.

Cheers,
Stephan


On Mon, Mar 2, 2015 at 5:02 PM, Matthias J. Sax <
mjsax@informatik.hu-berlin.de> wrote:

> I guess, Eclipse created those files. I delete them manually, what
> resolved the problem. I added "bin" to my local .gitignore and thus "git
> status" did not list the files and I was not aware the they are not part
> of the repository.
>
> As far as I know, "-Dmaven.test.skip=true" is equal to "-DskipTests".
>
> -Matthias
>
>
> On 03/02/2015 04:54 PM, Stephan Ewen wrote:
> > Matthias!
> >
> > The files should not exist. Has some IDE setup copied the files into the
> > "bin" directory (as part of compiling it without maven) ? It looks like
> you
> > are building it not through maven really...
> >
> > BTW: Does it make a difference whether you use "mvn
> -Dmaven.test.skip=true
> > clean install" or "mvn -DskipTests clean install"
> >
> > Stephan
> >
> >
> >
> >
> > On Mon, Mar 2, 2015 at 3:38 PM, Fabian Hueske <fhueske@gmail.com> wrote:
> >
> >> Hi Matthias,
> >>
> >> I just checked and could not reproduce the error.
> >> The files that Maven RAT complained about do not exist in Flink's master
> >> branch.
> >> I don't think they are put there as part of the build process.
> >>
> >> Best, Fabian
> >>
> >>
> >>
> >>
> >>
> >> 2015-03-02 15:09 GMT+01:00 Matthias J. Sax <
> mjsax@informatik.hu-berlin.de
> >>> :
> >>
> >>> Hi,
> >>>
> >>> if I start "mvn-Dmaven.test.skip=true clean install", the goal fails
> and
> >>> I get the following error:
> >>>
> >>>> Unapproved licenses:
> >>>>
> >>>>   flink-clients/bin/src/main/resources/web-docs/js/dagre-d3.js
> >>>>   flink-clients/bin/src/main/resources/web-docs/js/d3.js
> >>>>   flink-staging/flink-avro/bin/src/test/resources/avro/user.avsc
> >>>
> >>> It seems, that an APL2 compatible license is expected. Can anyone
> >>> comment it this issue.
> >>>
> >>> -> I am on branch flink/master
> >>>
> >>>
> >>> -Matthias
> >>>
> >>>
> >>
> >
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message