flink-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Márton Balassi <balassi.mar...@gmail.com>
Subject Re: [DISCUSS] Name of Expression API and DataSet abstraction
Date Mon, 16 Mar 2015 09:34:54 GMT
+1 for Max's suggestion.

On Mon, Mar 16, 2015 at 10:32 AM, Ufuk Celebi <uce@apache.org> wrote:

> On Fri, Mar 13, 2015 at 6:08 PM, Maximilian Michels <mxm@apache.org>
> wrote:
>
> >
> > Thanks for starting the discussion. We should definitely not keep
> > flink-expressions.
> >
> > I'm in favor of DataTable for the DataSet abstraction equivalent. For
> > consistency, the package name should then be flink-table. At first
> > sight, the name seems kind of plain but I think it is quite intuitive
> > because the API enables you to work in a SQL like fashion.
> >
>
>
> +1
>
> I think this is a very good suggestion. :-)
>
> (There is an associated issue, we shouldn't forget to close:
> https://issues.apache.org/jira/browse/FLINK-1623)
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message