flink-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paris Carbone <par...@kth.se>
Subject Re: [DISCUSS] Name of Expression API and DataSet abstraction
Date Sat, 21 Mar 2015 17:02:54 GMT
Both names look ok but if I had to choose I would go for the Relation API.
It defines a new DSL in contrast to data types (ie DataSet, DataStream) so it doesn’t have
to follow the same convention.
Plus, it is a single word with sufficient meaning.

Paris

On 21 Mar 2015, at 17:29, Fabian Hueske <fhueske@gmail.com<mailto:fhueske@gmail.com>>
wrote:

I'm in favor of Relation API because the API operates on a set of tuples
with a fixed (flat) schema which is known as relation from relational
databases.

Everybody who took a database intro class should be familiar with this term.
On Mar 21, 2015 5:14 PM, "Henry Saputra" <henry.saputra@gmail.com<mailto:henry.saputra@gmail.com>>
wrote:

I like the Relation or Relational. So maybe we could use DataRelation
as the abstraction?

- Henry

On Mon, Mar 16, 2015 at 9:30 AM, Fabian Hueske <fhueske@gmail.com<mailto:fhueske@gmail.com>>
wrote:
I am also more in favor of Rel and Relation, but DataTable nicely follows
the terms DataSet and DataStream.
On Mar 16, 2015 4:58 PM, "Aljoscha Krettek" <aljoscha@apache.org<mailto:aljoscha@apache.org>>
wrote:

I like Relation or Rel, is shorter.
On Mar 16, 2015 4:52 PM, "Hermann Gábor" <reckoner42@gmail.com<mailto:reckoner42@gmail.com>>
wrote:

+1 for DataTable

On Mon, Mar 16, 2015 at 4:11 PM Till Rohrmann <trohrmann@apache.org<mailto:trohrmann@apache.org>>
wrote:

+1 for DataTable

On Mon, Mar 16, 2015 at 10:34 AM, Márton Balassi <
balassi.marton@gmail.com<mailto:balassi.marton@gmail.com>

wrote:

+1 for Max's suggestion.

On Mon, Mar 16, 2015 at 10:32 AM, Ufuk Celebi <uce@apache.org>
wrote:

On Fri, Mar 13, 2015 at 6:08 PM, Maximilian Michels <
mxm@apache.org<mailto:mxm@apache.org>>
wrote:


Thanks for starting the discussion. We should definitely not
keep
flink-expressions.

I'm in favor of DataTable for the DataSet abstraction
equivalent.
For
consistency, the package name should then be flink-table. At
first
sight, the name seems kind of plain but I think it is quite
intuitive
because the API enables you to work in a SQL like fashion.



+1

I think this is a very good suggestion. :-)

(There is an associated issue, we shouldn't forget to close:
https://issues.apache.org/jira/browse/FLINK-1623)







Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message