flink-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chiwan Park <chiwanp...@icloud.com>
Subject Re: Streaming temporal operator (join, cross...) syntax
Date Mon, 05 Jan 2015 14:16:07 GMT
I also think that the first one is more intuitive.

—
Chiwan Park (Sent with iPhone)


> On Jan 5, 2015, at 10:51 PM, Till Rohrmann <trohrmann@apache.org> wrote:
> 
> I also prefer the first alternative.
> 
> Greets,
> Till
> 
> On Mon, Jan 5, 2015 at 2:01 PM, Stephan Ewen <sewen@apache.org> wrote:
> 
>> I think the first one is more intuitive as well..
>> 
>> Greetings,
>> Stephan
>> 
>> On Mon, Jan 5, 2015 at 1:26 PM, Szabó Péter <nemderogatorius@gmail.com>
>> wrote:
>> 
>>> The first one looks great and more compact. I think, the second one is
>> less
>>> intuitive.
>>> 
>>> Cheers,
>>> Peter
>>> 
>>> 2015-01-05 10:46 GMT+01:00 Gyula Fóra <gyfora@apache.org>:
>>> 
>>>> Hey guys,
>>>> 
>>>> We have been discussing the possible syntaxes for doing temporal
>>> operators
>>>> on DataStreams(join, corss, cogroup etc) with Paris and we have come up
>>>> with two alternatives.
>>>> 
>>>> 1.
>>>> 
>>>> ds1.join(ds2).onWindow(5, seconds).every(2,
>>>> seconds).where(...).equalTo(...)
>>>> 
>>>> 2.
>>>> 
>>>> ds1.connect(ds2).onWindow(5, seconds).every(2,
>>>> seconds).join().where(...).equalTo(...)
>>>> 
>>>> 
>>>> 
>>>> Basically the difference is that in the second case we produce a binary
>>>> stream of 2 types by the connect method and we create a window on that
>>>> before join/cross. While in the first case the join/cross/etc is the
>>> method
>>>> of the DataStream itself and we define the window after calling
>>>> join/cross/etc
>>>> 
>>>> We currently have the first one.
>>>> 
>>>> Which one do you think is the more intuitive? (Or propose an
>> alternative)
>>>> 
>>>> Cheers,
>>>> Gyula & Paris
>>>> 
>>> 
>> 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message