flink-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gyula Fora <gyula.f...@gmail.com>
Subject Re: Eclipse import errors after akka update
Date Fri, 19 Dec 2014 05:58:54 GMT
Hey, 

Thanks Till for the description, I actually thought that I had the things set already what
you described since I have been working on the scala code anyways. 

It turned out that the xplugin path self updated itself by pasting my workspace path in front
of path. So when I checked if I have everything set it looked good since the beginning of
the path is same but was actually an invalid…

Sorry I missed that somehow

Gyula

> On 19 Dec 2014, at 02:38, Till Rohrmann <trohrmann@apache.org> wrote:
> 
> Hi Gyula,
> 
> I just tried to build the current master with Eclipse Luna and the ScalaIDE
> 4.0.0 and it worked. What you have to make sure is that the Scala compiler
> for the sub modules requiring Scala is set to Scala 2.10. This is
> configured under Properties (Module) -> Scala Compiler. Otherwise you get
> errors saying that a library is build for a wrong Scala version (namely
> 2.10). The sub modules requiring a Scala nature are flink-runtime,
> flink-scala, flink-scala-examples, flink-test-utils and flink-tests, if I'm
> not mistaken.
> 
> The second thing are the quasi quotes in the flink-scala module. Either you
> simply close the project and everything should work or you add the required
> Scala macro plugin paradise_2.10.4-2.0.1.jar to the compiler. You have to
> specify it in Properties (Module) -> Scala compiler -> Advanced -> Xplugin.
> You should find the paradise jar in your local maven repository, if you
> built the project at least once with maven: Something like
> ~/.m2/repository/org/scalamacros/paradise_2.10.4/2.0.1/paradise_2.10.4-2.0.1.jar.
> That is basically the same thing you have to do in IntelliJ as well to be
> able to compile the flink-scala module out of IntelliJ.
> 
> I hope this solves your problems with Eclipse and sorry for the trouble I
> caused you with my changes.
> 
> Greets,
> 
> Till
> 
> On Fri, Dec 19, 2014 at 1:34 AM, Stephan Ewen <sewen@apache.org> wrote:
>> 
>> I will try and look into this tomorrow. I suspect it is something either
>> about Scala versions or compiler plugins...
>> 
>> Greetings,
>> Stephan
>> Am 19.12.2014 00:23 schrieb "Gyula Fóra" <gyula.fora@gmail.com>:
>> 
>>> Hey guys,
>>> 
>>> Since the last Akka update pull request from Till, I am getting a lot of
>>> import errors (AkkaUtils, and other related packages) in Eclipse and I
>>> cannot build the project. With Eclipse Luna there is no chance it gives
>>> like a 100 erros. With the eclipse scala ide based on Kepler I still get
>>> scala compilation and import errors.
>>> 
>>> For instance:
>>> 
>>> in TypeInfomrationGen.scala:
>>> "value q is not member of StringContext"
>>> 
>>> 
>>> Any ideas what could cause these and how to fix it?
>>> Is there anyone who can actually build this in eclipse?
>>> 
>>> Cheers,
>>> Gyula
>>> 
>> 


Mime
View raw message