flink-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Markus Holzemer <holzemer.mar...@googlemail.com>
Subject Re: [flink-graph] Tests failing on Windows
Date Fri, 14 Nov 2014 18:20:08 GMT
Hi,
usually the Windows Tests fail because some file URIs are hard-coded in
Linux style.
Perhaps you can do a quick fix yourself otherwise I can have a look at the
issue as soon as I find the time.

Best,
Markus
Am 14.11.2014 10:16 schrieb "Dániel Bali" <balijanosdaniel@gmail.com>:

> Hi!
>
> It's the snapshot version.
>
> Regards,
> Daniel
>
> 2014-11-14 18:09 GMT+01:00 Stephan Ewen <sewen@apache.org>:
>
> > Hi!
> >
> > Just to make sure: The latest version means the latest snapshot version
> > (0.8-incubating-SNAPSHOT), or the latest release version (0.7.0) ?
> >
> > Stephan
> >
> >
> > On Fri, Nov 14, 2014 at 5:48 PM, Dániel Bali <balijanosdaniel@gmail.com>
> > wrote:
> >
> > > Hello!
> > >
> > > I have a fork of flink-graph <
> > https://github.com/project-flink/flink-graph>
> > > and
> > > some of the tests fail on Windows, even though they pass on Ubuntu. Is
> > > there anybody using Flink on Windows who could take a look at this?
> > >
> > > The test that fails is TestMapVertices. The first 2 cases always pass
> and
> > > the last 3 fail. If I switch the order of test cases, the previously
> > failed
> > > tests will pass. From the exception it looks like an io issue, but it's
> > > very strange that 2 tests pass.
> > >
> > > Here is the full log that I get when running the test. The relevant
> > > exceptions are at the end.
> > > https://gist.github.com/balidani/f8795da0679b26b80b2a
> > >
> > > Here is the failure trace:
> > > https://gist.github.com/balidani/5b7b8cd8febe87f83a50
> > >
> > > This is on Windows 7 (Version 6.1.7601), with the latest version of
> > Flink.
> > >
> > > Thanks!
> > >
> > > Regards,
> > > Daniel
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message