flink-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Metzger <rmetz...@apache.org>
Subject Re: build_docs.sh not working
Date Thu, 14 Aug 2014 14:33:40 GMT
Hi,
You need the latest jekyll, at least version 2.1.0, as well as "redcarpet"
and pygmentize". The script should check if the jekyll version is correct
and if the other two tools are available.

Robert


On Thu, Aug 14, 2014 at 4:28 PM, Fabian Hueske <fhueske@apache.org> wrote:

> When executing ./docs/build_docs.sh I get the following error message:
>
> Configuration file:
> /home/fhueske/Development/projects/flink/docs/_config.yml
>       Source: /home/fhueske/Development/projects/flink/docs
>       Destination: /home/fhueske/Development/projects/flink/docs/target
>       Generating...   Liquid Exception: wrong number of arguments(1 for 0)
> in _layouts/docs.html
> error: wrong number of arguments(1 for 0). Use --trace to view backtrace
>
> Which jekyll version is required for the script? Are there any other
> dependencies?
>
> Cheers, Fabian
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message