flink-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ufuk Celebi (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-917) Rename netty IO Thread count parameters
Date Tue, 10 Jun 2014 22:01:02 GMT

    [ https://issues.apache.org/jira/browse/FLINK-917?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14027097#comment-14027097
] 

Ufuk Celebi commented on FLINK-917:
-----------------------------------

+1

What about `taskmanager.io.numOutThreads` and `numInThreads` respectively?

> Rename netty IO Thread count parameters
> ---------------------------------------
>
>                 Key: FLINK-917
>                 URL: https://issues.apache.org/jira/browse/FLINK-917
>             Project: Flink
>          Issue Type: Bug
>            Reporter: GitHub Import
>              Labels: github-import
>             Fix For: pre-apache
>
>
> How about we rename the config parameters for `taskmanager.netty.numOutThreads` and `taskmanager.netty.numInThreads`?
That way we make it "independent" of the underlying implementation. The same parameter should
also configure the number of I/O threads if we should choose to go with zeroMQ for streaming,
or so...
> ---------------- Imported from GitHub ----------------
> Url: https://github.com/stratosphere/stratosphere/issues/917
> Created by: [StephanEwen|https://github.com/StephanEwen]
> Labels: 
> Created at: Sun Jun 08 16:12:44 CEST 2014
> State: open



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message