flink-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From u..@apache.org
Subject [1/3] flink git commit: [FLINK-8308] Remove explicit yajl-ruby dependency, update Jekyll to 3+
Date Fri, 16 Feb 2018 08:52:47 GMT
Repository: flink
Updated Branches:
  refs/heads/release-1.4 054af9974 -> cc76c323f


[FLINK-8308] Remove explicit yajl-ruby dependency, update Jekyll to 3+


Project: http://git-wip-us.apache.org/repos/asf/flink/repo
Commit: http://git-wip-us.apache.org/repos/asf/flink/commit/50b64847
Tree: http://git-wip-us.apache.org/repos/asf/flink/tree/50b64847
Diff: http://git-wip-us.apache.org/repos/asf/flink/diff/50b64847

Branch: refs/heads/release-1.4
Commit: 50b648473f1ec7e4e11f511c6027d66694db7e7b
Parents: 054af99
Author: Steven Langbroek <steven@digitaaldier.nl>
Authored: Wed Jan 31 17:26:28 2018 +0100
Committer: Ufuk Celebi <uce@apache.org>
Committed: Fri Feb 16 09:49:14 2018 +0100

----------------------------------------------------------------------
 docs/Gemfile                   |   8 +--
 docs/Gemfile.lock              |  99 ++++++++++++++++-------------------
 docs/_config.yml               |   7 +--
 docs/_layouts/plain.html       |   2 +-
 docs/_plugins/highlightCode.rb | 100 ------------------------------------
 docs/build_docs.sh             |   1 -
 docs/ruby2/Gemfile             |  32 ------------
 docs/ruby2/Gemfile.lock        |  84 ------------------------------
 8 files changed, 47 insertions(+), 286 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/flink/blob/50b64847/docs/Gemfile
----------------------------------------------------------------------
diff --git a/docs/Gemfile b/docs/Gemfile
index b642e76..683bd55 100644
--- a/docs/Gemfile
+++ b/docs/Gemfile
@@ -18,14 +18,10 @@
 
 source 'https://rubygems.org'
 
-ruby '>= 1.9.0'
+ruby '>= 2.1.0'
 
-gem 'jekyll', '2.5.3'
-gem 'kramdown', '1.10.0'
+gem 'jekyll', '3.7.2'
 gem 'addressable', '2.4.0'
 gem 'octokit', '~> 4.3.0'
-gem 'pygments.rb', '0.6.3'
 gem 'therubyracer', '0.12.2'
 gem 'json', '2.0.4'
-gem 'yajl-ruby', '1.2.2'
-gem 'jekyll-coffeescript', '1.0.2'

http://git-wip-us.apache.org/repos/asf/flink/blob/50b64847/docs/Gemfile.lock
----------------------------------------------------------------------
diff --git a/docs/Gemfile.lock b/docs/Gemfile.lock
index 889a5fe..ab3a1d3 100644
--- a/docs/Gemfile.lock
+++ b/docs/Gemfile.lock
@@ -2,94 +2,81 @@ GEM
   remote: https://rubygems.org/
   specs:
     addressable (2.4.0)
-    blankslate (2.1.2.4)
-    classifier-reborn (2.0.4)
-      fast-stemmer (~> 1.0)
-    coffee-script (2.4.1)
-      coffee-script-source
-      execjs
-    coffee-script-source (1.11.1)
-    colorator (0.1)
-    execjs (2.7.0)
+    colorator (1.1.0)
+    concurrent-ruby (1.0.5)
+    em-websocket (0.5.1)
+      eventmachine (>= 0.12.9)
+      http_parser.rb (~> 0.6.0)
+    eventmachine (1.2.5)
     faraday (0.9.2)
       multipart-post (>= 1.2, < 3)
-    fast-stemmer (1.0.2)
-    ffi (1.9.14)
-    jekyll (2.5.3)
-      classifier-reborn (~> 2.0)
-      colorator (~> 0.1)
-      jekyll-coffeescript (~> 1.0)
-      jekyll-gist (~> 1.0)
-      jekyll-paginate (~> 1.0)
+    ffi (1.9.18)
+    forwardable-extended (2.6.0)
+    http_parser.rb (0.6.0)
+    i18n (0.9.3)
+      concurrent-ruby (~> 1.0)
+    jekyll (3.7.2)
+      addressable (~> 2.4)
+      colorator (~> 1.0)
+      em-websocket (~> 0.5)
+      i18n (~> 0.7)
       jekyll-sass-converter (~> 1.0)
-      jekyll-watch (~> 1.1)
-      kramdown (~> 1.3)
-      liquid (~> 2.6.1)
+      jekyll-watch (~> 2.0)
+      kramdown (~> 1.14)
+      liquid (~> 4.0)
       mercenary (~> 0.3.3)
-      pygments.rb (~> 0.6.0)
-      redcarpet (~> 3.1)
+      pathutil (~> 0.9)
+      rouge (>= 1.7, < 4)
       safe_yaml (~> 1.0)
-      toml (~> 0.1.0)
-    jekyll-coffeescript (1.0.2)
-      coffee-script (~> 2.2)
-      coffee-script-source (~> 1.11.1)
-    jekyll-gist (1.4.0)
-      octokit (~> 4.2)
-    jekyll-paginate (1.1.0)
-    jekyll-sass-converter (1.5.0)
+    jekyll-sass-converter (1.5.1)
       sass (~> 3.4)
-    jekyll-watch (1.5.0)
-      listen (~> 3.0, < 3.1)
+    jekyll-watch (2.0.0)
+      listen (~> 3.0)
     json (2.0.4)
-    kramdown (1.10.0)
-    libv8 (3.16.14.17)
-    liquid (2.6.3)
-    listen (3.0.8)
+    kramdown (1.16.2)
+    libv8 (3.16.14.19)
+    liquid (4.0.0)
+    listen (3.1.5)
       rb-fsevent (~> 0.9, >= 0.9.4)
       rb-inotify (~> 0.9, >= 0.9.7)
+      ruby_dep (~> 1.2)
     mercenary (0.3.6)
     multipart-post (2.0.0)
     octokit (4.3.0)
       sawyer (~> 0.7.0, >= 0.5.3)
-    parslet (1.5.0)
-      blankslate (~> 2.0)
-    posix-spawn (0.3.12)
-    pygments.rb (0.6.3)
-      posix-spawn (~> 0.3.6)
-      yajl-ruby (~> 1.2.0)
-    rb-fsevent (0.9.8)
-    rb-inotify (0.9.7)
-      ffi (>= 0.5.0)
-    redcarpet (3.3.4)
+    pathutil (0.16.1)
+      forwardable-extended (~> 2.6)
+    rb-fsevent (0.10.2)
+    rb-inotify (0.9.10)
+      ffi (>= 0.5.0, < 2)
     ref (2.0.0)
+    rouge (3.1.1)
+    ruby_dep (1.5.0)
     safe_yaml (1.0.4)
-    sass (3.4.22)
+    sass (3.5.5)
+      sass-listen (~> 4.0.0)
+    sass-listen (4.0.0)
+      rb-fsevent (~> 0.9, >= 0.9.4)
+      rb-inotify (~> 0.9, >= 0.9.7)
     sawyer (0.7.0)
       addressable (>= 2.3.5, < 2.5)
       faraday (~> 0.8, < 0.10)
     therubyracer (0.12.2)
       libv8 (~> 3.16.14.0)
       ref
-    toml (0.1.2)
-      parslet (~> 1.5.0)
-    yajl-ruby (1.2.2)
 
 PLATFORMS
   ruby
 
 DEPENDENCIES
   addressable (= 2.4.0)
-  jekyll (= 2.5.3)
-  jekyll-coffeescript (= 1.0.2)
+  jekyll (= 3.7.2)
   json (= 2.0.4)
-  kramdown (= 1.10.0)
   octokit (~> 4.3.0)
-  pygments.rb (= 0.6.3)
   therubyracer (= 0.12.2)
-  yajl-ruby (= 1.2.2)
 
 RUBY VERSION
    ruby 2.3.1p112
 
 BUNDLED WITH
-   1.15.0
+   1.16.1

http://git-wip-us.apache.org/repos/asf/flink/blob/50b64847/docs/_config.yml
----------------------------------------------------------------------
diff --git a/docs/_config.yml b/docs/_config.yml
index 866f346..4c52b73 100644
--- a/docs/_config.yml
+++ b/docs/_config.yml
@@ -76,12 +76,7 @@ defaults:
       layout: plain
       nav-pos: 99999 # Move to end if no pos specified
 
-markdown: KramdownPygments
-highlighter: pygments
+host: 0.0.0.0
 
 kramdown:
-  input: GFM # GitHub syntax
-  hard_wrap: false # Don't translate new lines to <br>s
   toc_levels: 1..3 # Include h1-h3 for ToC
-
-host: 0.0.0.0

http://git-wip-us.apache.org/repos/asf/flink/blob/50b64847/docs/_layouts/plain.html
----------------------------------------------------------------------
diff --git a/docs/_layouts/plain.html b/docs/_layouts/plain.html
index e991f78..7bd0030 100644
--- a/docs/_layouts/plain.html
+++ b/docs/_layouts/plain.html
@@ -26,7 +26,7 @@ under the License.
 {% for i in (1..10) %}
   {% assign active_pages = active_pages | push: active %}
   {% if active.nav-parent_id %}
-    {% assign next = (site.pages | where: "nav-id" , active.nav-parent_id ) %}
+    {% assign next = site.pages | where: "nav-id" , active.nav-parent_id %}
     {% if next.size > 0 %}
       {% assign active = next[0] %}
     {% else %}

http://git-wip-us.apache.org/repos/asf/flink/blob/50b64847/docs/_plugins/highlightCode.rb
----------------------------------------------------------------------
diff --git a/docs/_plugins/highlightCode.rb b/docs/_plugins/highlightCode.rb
deleted file mode 100644
index 74f6d6f..0000000
--- a/docs/_plugins/highlightCode.rb
+++ /dev/null
@@ -1,100 +0,0 @@
-# Licensed to the Apache Software Foundation (ASF) under one
-# or more contributor license agreements.  See the NOTICE file
-# distributed with this work for additional information
-# regarding copyright ownership.  The ASF licenses this file
-# to you under the Apache License, Version 2.0 (the
-# "License"); you may not use this file except in compliance
-# with the License.  You may obtain a copy of the License at
-# 
-# http://www.apache.org/licenses/LICENSE-2.0
-# 
-# Unless required by applicable law or agreed to in writing,
-# software distributed under the License is distributed on an
-# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
-# KIND, either express or implied.  See the License for the
-# specific language governing permissions and limitations
-# under the License.
-
-# This file was derived from https://github.com/navarroj/krampygs 
-#   written by Juan Navarro and released under the Unlicense (http://unlicense.org).
-
-require 'kramdown'
-require 'pygments'
-
-module Kramdown
-  module Converter
-
-    class Pygs < Html
-    
-      def convert_codeblock(el, indent)
-        attr = el.attr.dup
-        lang = extract_code_language!(attr) || @options[:kramdown_default_lang]
-        code = pygmentize(el.value, lang)
-        code_attr = {}
-        code_attr['class'] = "language-#{lang}" if lang
-        "#{' '*indent}<div class=\"highlight\"><pre#{html_attributes(attr)}><code#{html_attributes(code_attr)}>#{code}</code></pre></div>\n"
-      end
-
-      def convert_codespan(el, indent)
-        attr = el.attr.dup
-        lang = extract_code_language!(attr) || @options[:kramdown_default_lang]
-        code = pygmentize(el.value, lang)
-        if lang
-          attr['class'] = "highlight"
-          if attr.has_key?('class')
-            attr['class'] += " language-#{lang}"
-          else
-            attr['class'] = "language-#{lang}"
-          end
-        end
-        "<code#{html_attributes(attr)}>#{code}</code>"
-      end
-      
-      def pygmentize(code, lang)
-        if lang
-          Pygments.highlight(code,
-            :lexer => lang,
-            :options => { :encoding => 'utf-8', :nowrap => true })
-        else
-          escape_html(code)
-        end
-      end
-
-    end
-  end
-end
-
-class Jekyll::Converters::Markdown::KramdownPygments
-
-  def initialize(config)
-    require 'kramdown'
-    @config = config
-  rescue LoadError
-    STDERR.puts 'You are missing a library required for Markdown. Please run:'
-    STDERR.puts '  $ [sudo] gem install kramdown'
-    raise FatalException.new("Missing dependency: kramdown")
-  end
-  
-  def matches(ext)
-    ext =~ /^\.md$/i
-  end
-
-  def output_ext(ext)
-    ".html"
-  end
-
-  def convert(content)
-    html = Kramdown::Document.new(content, {
-        :auto_ids             => @config['kramdown']['auto_ids'],
-        :footnote_nr          => @config['kramdown']['footnote_nr'],
-        :entity_output        => @config['kramdown']['entity_output'],
-        :toc_levels           => @config['kramdown']['toc_levels'],
-        :smart_quotes         => @config['kramdown']['smart_quotes'],
-        :coderay_default_lang => @config['kramdown']['default_lang'],
-        :input                => @config['kramdown']['input'],
-        :hard_wrap            => @config['kramdown']['hard_wrap']
-    }).to_pygs
-    return html
-  end
-
-end
\ No newline at end of file

http://git-wip-us.apache.org/repos/asf/flink/blob/50b64847/docs/build_docs.sh
----------------------------------------------------------------------
diff --git a/docs/build_docs.sh b/docs/build_docs.sh
index cbdd1d4..0ef7170 100755
--- a/docs/build_docs.sh
+++ b/docs/build_docs.sh
@@ -54,7 +54,6 @@ while getopts "pi" opt; do
 		;;
 		i)
 		[[ `ruby -v` =~ 'ruby 1' ]] && echo "Error: building the docs with the incremental
option requires at least ruby 2.0" && exit 1
-		cd ruby2
 		bundle install --path .rubydeps
 		JEKYLL_CMD="liveserve --baseurl= --watch --incremental"
 		;;

http://git-wip-us.apache.org/repos/asf/flink/blob/50b64847/docs/ruby2/Gemfile
----------------------------------------------------------------------
diff --git a/docs/ruby2/Gemfile b/docs/ruby2/Gemfile
deleted file mode 100644
index f71ceb0..0000000
--- a/docs/ruby2/Gemfile
+++ /dev/null
@@ -1,32 +0,0 @@
-################################################################################
-#  Licensed to the Apache Software Foundation (ASF) under one
-#  or more contributor license agreements.  See the NOTICE file
-#  distributed with this work for additional information
-#  regarding copyright ownership.  The ASF licenses this file
-#  to you under the Apache License, Version 2.0 (the
-#  "License"); you may not use this file except in compliance
-#  with the License.  You may obtain a copy of the License at
-#
-#      http://www.apache.org/licenses/LICENSE-2.0
-#
-#  Unless required by applicable law or agreed to in writing, software
-#  distributed under the License is distributed on an "AS IS" BASIS,
-#  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-#  See the License for the specific language governing permissions and
-# limitations under the License.
-################################################################################
-
-source 'https://rubygems.org'
-
-ruby '~> 2'
-
-gem 'jekyll', '~> 3.3.0'
-gem 'kramdown', '~> 1.13.0'
-gem 'json', '2.0.4'
-group :jekyll_plugins do
-  gem 'hawkins'
-end
-gem 'pygments.rb', '0.6.3'
-gem 'therubyracer', '0.12.2'
-gem 'yajl-ruby', '1.2.2'
-gem 'jekyll-coffeescript', '1.0.2'

http://git-wip-us.apache.org/repos/asf/flink/blob/50b64847/docs/ruby2/Gemfile.lock
----------------------------------------------------------------------
diff --git a/docs/ruby2/Gemfile.lock b/docs/ruby2/Gemfile.lock
deleted file mode 100644
index ade8cf7..0000000
--- a/docs/ruby2/Gemfile.lock
+++ /dev/null
@@ -1,84 +0,0 @@
-GEM
-  remote: https://rubygems.org/
-  specs:
-    addressable (2.5.0)
-      public_suffix (~> 2.0, >= 2.0.2)
-    coffee-script (2.4.1)
-      coffee-script-source
-      execjs
-    coffee-script-source (1.11.1)
-    colorator (1.1.0)
-    em-websocket (0.5.1)
-      eventmachine (>= 0.12.9)
-      http_parser.rb (~> 0.6.0)
-    eventmachine (1.2.1)
-    execjs (2.7.0)
-    ffi (1.9.14)
-    forwardable-extended (2.6.0)
-    hawkins (2.0.4)
-      em-websocket (~> 0.5)
-      jekyll (~> 3.1)
-    http_parser.rb (0.6.0)
-    jekyll (3.3.1)
-      addressable (~> 2.4)
-      colorator (~> 1.0)
-      jekyll-sass-converter (~> 1.0)
-      jekyll-watch (~> 1.1)
-      kramdown (~> 1.3)
-      liquid (~> 3.0)
-      mercenary (~> 0.3.3)
-      pathutil (~> 0.9)
-      rouge (~> 1.7)
-      safe_yaml (~> 1.0)
-    jekyll-coffeescript (1.0.2)
-      coffee-script (~> 2.2)
-      coffee-script-source (~> 1.11.1)
-    jekyll-sass-converter (1.5.0)
-      sass (~> 3.4)
-    jekyll-watch (1.5.0)
-      listen (~> 3.0, < 3.1)
-    json (2.0.4)
-    kramdown (1.13.1)
-    libv8 (3.16.14.17)
-    liquid (3.0.6)
-    listen (3.0.8)
-      rb-fsevent (~> 0.9, >= 0.9.4)
-      rb-inotify (~> 0.9, >= 0.9.7)
-    mercenary (0.3.6)
-    pathutil (0.14.0)
-      forwardable-extended (~> 2.6)
-    posix-spawn (0.3.12)
-    public_suffix (2.0.4)
-    pygments.rb (0.6.3)
-      posix-spawn (~> 0.3.6)
-      yajl-ruby (~> 1.2.0)
-    rb-fsevent (0.9.8)
-    rb-inotify (0.9.7)
-      ffi (>= 0.5.0)
-    ref (2.0.0)
-    rouge (1.11.1)
-    safe_yaml (1.0.4)
-    sass (3.4.22)
-    therubyracer (0.12.2)
-      libv8 (~> 3.16.14.0)
-      ref
-    yajl-ruby (1.2.2)
-
-PLATFORMS
-  ruby
-
-DEPENDENCIES
-  hawkins
-  jekyll (~> 3.3.0)
-  jekyll-coffeescript (= 1.0.2)
-  json (= 2.0.4)
-  kramdown (~> 1.13.0)
-  pygments.rb (= 0.6.3)
-  therubyracer (= 0.12.2)
-  yajl-ruby (= 1.2.2)
-
-RUBY VERSION
-   ruby 2.3.0p0
-
-BUNDLED WITH
-   1.13.6


Mime
View raw message