flink-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From m..@apache.org
Subject flink git commit: [FLINK-2981] [docs] update requirements in docs/README
Date Fri, 06 Nov 2015 11:22:49 GMT
Repository: flink
Updated Branches:
  refs/heads/master b80d89a64 -> f33f33206


[FLINK-2981] [docs] update requirements in docs/README

* added libraries and versions

This closes #1335.


Project: http://git-wip-us.apache.org/repos/asf/flink/repo
Commit: http://git-wip-us.apache.org/repos/asf/flink/commit/f33f3320
Tree: http://git-wip-us.apache.org/repos/asf/flink/tree/f33f3320
Diff: http://git-wip-us.apache.org/repos/asf/flink/diff/f33f3320

Branch: refs/heads/master
Commit: f33f3320619b29fcc41f3827260330e452f4ada7
Parents: b80d89a
Author: Martin Junghanns <m.junghanns@mailbox.org>
Authored: Fri Nov 6 11:33:43 2015 +0100
Committer: Maximilian Michels <mxm@apache.org>
Committed: Fri Nov 6 12:21:16 2015 +0100

----------------------------------------------------------------------
 docs/README.md | 20 ++++++++++++--------
 1 file changed, 12 insertions(+), 8 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/flink/blob/f33f3320/docs/README.md
----------------------------------------------------------------------
diff --git a/docs/README.md b/docs/README.md
index 206b04c..a042ea5 100644
--- a/docs/README.md
+++ b/docs/README.md
@@ -6,15 +6,19 @@ http://flink.apache.org/ is also generated from the files found here.
 
 # Requirements
 
-We use Markdown to write and Jekyll to translate the documentation to static HTML. You can
install
-all needed software via:
-
-    gem install jekyll
-    gem install kramdown
+We use Markdown to write and Jekyll to translate the documentation to static HTML. Kramdown
is 
+needed for Markdown processing and the Python based Pygments is used for syntax highlighting.
To run
+Javascript code from Ruby, you need to install a javascript runtime (e.g. `therubyracer`).
You can 
+install all needed software via the following commands:
+
+    gem install jekyll -v 2.5.3
+    gem install kramdown -v 1.9.0
+    gem install pygments.rb -v 0.6.3
+    gem install therubyracer -v 0.12.2
     sudo easy_install Pygments
-
-Kramdown is needed for Markdown processing and the Python based Pygments is used for syntax
-highlighting.
+    
+Note that in Ubuntu based systems, it may be necessary to install the `ruby-dev` and 
+`python-setuptools` packages via apt.
 
 # Build
 


Mime
View raw message