flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Spierenburg <peter.spierenb...@nautel.com>
Subject Re: How do I install FlexJS and FDT on Ubuntu 16.04
Date Fri, 01 Sep 2017 15:24:44 GMT
Ok,


I followed the instructions at https://davidwalsh.name/upgrade-nodejs

[https://davidwalsh.name/wp-content/themes/punky/images/logo.png]<https://davidwalsh.name/upgrade-nodejs>

Upgrade Node.js via NPM - David Walsh Blog<https://davidwalsh.name/upgrade-nodejs>
davidwalsh.name
Learn how to upgrade Node.js with the NPM package system!

to upgrade my nodejs to the latest 8.4.0 release.

Now my error is:

sudo npm install flexjs -g
npm WARN deprecated wrench@1.5.9: wrench.js is deprecated! You should check out fs-extra (https://github.com/jprichardson/node-fs-extra)
for any operations you were using wrench for. Thanks for all the usage over the years.
npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid
a RegExp DoS issue
/usr/local/bin/asjsc -> /usr/local/lib/node_modules/flexjs/js/bin/asjscnpm
/usr/local/bin/asjscompc -> /usr/local/lib/node_modules/flexjs/js/bin/asjscompcnpm
/usr/local/bin/compc -> /usr/local/lib/node_modules/flexjs/js/bin/compcnpm
/usr/local/bin/mxmlc -> /usr/local/lib/node_modules/flexjs/js/bin/mxmlcnpm
/usr/local/bin/externc -> /usr/local/lib/node_modules/flexjs/js/bin/externcnpm
/usr/local/bin/asnodec -> /usr/local/lib/node_modules/flexjs/js/bin/asnodecnpm

> flexjs@0.8.0 postinstall /usr/local/lib/node_modules/flexjs
> node dependencies/download_dependencies.js

prompt: Apache FlexJS includes an optional component set
that uses fonts from designmodo.com.  The font
files are subject to and governed by the
Creative Commons Attribution-NonCommercial-NoDerivs 3.0
Unported license: http://creativecommons.org/licenses/by-nc-nd/3.0/
This license is not compatible with the Apache v2 license.
Do you want to install the designmodo fonts?
This is an optional component (y/n):  y
Downloading FlatUI from https://github.com/designmodo/Flat-UI/archive/2.2.2.zip
internal/streams/legacy.js:59
      throw er; // Unhandled stream error in pipe.
      ^

Error: ENOENT: no such file or directory, open './downloads/2.2.2.zip'
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! flexjs@0.8.0 postinstall: `node dependencies/download_dependencies.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the flexjs@0.8.0 postinstall script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output
above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/user/.npm/_logs/2017-09-01T15_21_27_387Z-debug.log




________________________________
From: Josh Tynjala <joshtynjala@gmail.com>
Sent: September 1, 2017 12:12:55 PM
To: users@flex.apache.org
Subject: Re: How do I install FlexJS and FDT on Ubuntu 16.04

I would recommend upgrading to at least Node 6, since that's the latest LTS
release.

Additionally, you may need to use sudo when installing packages globally
with npm.

- Josh

On Sep 1, 2017 6:52 AM, "Peter Spierenburg" <peter.spierenburg@nautel.com>
wrote:

https://cwiki.apache.org/confluence/display/FLEX/
Getting+Started+With+FlexJS#GettingStartedWithFlexJS-ApacheFlexInstaller

Getting Started With FlexJS - Apache Flex - Apache ...<
https://cwiki.apache.org/confluence/display/FLEX/
Getting+Started+With+FlexJS#GettingStartedWithFlexJS-ApacheFlexInstaller>
cwiki.apache.org
Application developers can create applications with Apache FlexJS via a
number IDEs, from the command line, with Ant, and soon, Maven. Below are
links to instructions ...

I am trying to follow the instructions above, and I am failing miserably.


When I follow the instructions under "Installing FlexJS via the Node
Package Manager (npm)" I get the following error:


npm ERR! Linux 4.10.0-33-generic
npm ERR! argv "/usr/bin/nodejs" "/usr/bin/npm" "install" "flexjs" "-g"
npm ERR! node v4.2.6
npm ERR! npm  v3.5.2
npm ERR! file sh
npm ERR! code ELIFECYCLE
npm ERR! errno ENOENT
npm ERR! syscall spawn

npm ERR! flexjs@0.8.0 postinstall: `node dependencies/download_
dependencies.js`
npm ERR! spawn ENOENT
npm ERR!
npm ERR! Failed at the flexjs@0.8.0 postinstall script 'node
dependencies/download_dependencies.js'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the flexjs package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node dependencies/download_dependencies.js
npm ERR! You can get information on how to open an issue for this project
with:
npm ERR!     npm bugs flexjs
npm ERR! Or if that isn't available, you can get their info via:
npm ERR!     npm owner ls flexjs
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR!     /home/user/npm-debug.log


When I follow the instructions under "Installing FlexJS by Downloading a
Binary Package" I get the following error:

Buildfile: /home/user/apache-flex-flexjs-0.8.0-bin/installer.xml
      [get] Getting: http://flex.apache.org/installer/properties/flexjs/
en_US.properties
      [get] To: /home/user/apache-flex-flexjs-0.8.0-bin/en_US.properties

get-data:
      [get] Getting: http://flex.apache.org/installer/sdk-installer-
config-4.0.xml?ts=201709011343
      [get] To: /home/user/apache-flex-flexjs-0.8.0-bin/sdk-installer-
config-4.0.xml

BUILD FAILED
/home/user/apache-flex-flexjs-0.8.0-bin/installer.xml:158: Reference
air.sdk.server.linux.14.0 not found.

Total time: 1 second


I don't suppose there is a debian package that I can just install?

Peter.

This communication, including any attached documentation, is intended only
for the person or entity to which it is addressed, and may contain
confidential, personal, and/or privileged information. Any unauthorized
disclosure, copying, or taking action on the contents is strictly
prohibited. If you have received this message in error, please contact us
immediately so we may correct our records. Please then delete or destroy
the original transmission and any subsequent reply. Thank you.
This communication, including any attached documentation, is intended only for the person
or entity to which it is addressed, and may contain confidential, personal, and/or privileged
information. Any unauthorized disclosure, copying, or taking action on the contents is strictly
prohibited. If you have received this message in error, please contact us immediately so we
may correct our records. Please then delete or destroy the original transmission and any subsequent
reply. Thank you.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message