flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christofer Dutz <christofer.d...@c-ware.de>
Subject Re: Just compiled BlazeDS - not sure how to install on Tomcat
Date Sun, 16 Apr 2017 22:03:32 GMT
Hi Bruce,

You made me notice that I still need to merge the last release to master for BlazeDS. For
now, I would suggest to checkout the develop branch.
I think things have become easier with latest updates. I was never a big fan of the fat war
approach of the Adobe releases (even if the new one also produces wars). 

With the full transition to Maven we have also just released some BlazeDS Archetypes. These
are templates Maven can use to create new projects based upon a template.

To create a new project, running BlazeDS in a Spring-Boot application running in Tomcat or
Jetty, just execute the following command:

mvn archetype:generate -DarchetypeGroupId=org.apache.flex.blazeds -DarchetypeArtifactId=blazeds-spring-boot-example-archetype
-DarchetypeVersion=4.7.3

This will generate a new maven module as your project. You can build it with:

mvn package

And run the application with this:

mvn spring-boot:run

Hope that helps,
    Chris


Am 16.04.17, 22:07 schrieb "Bruce Hopkins" <javaspaces@icloud.com>:

    Hi all,
    
    Several years ago, I used BlazeDS 3 with Tomcat. The binaries were in .WAR files, and
deployment and testing was easy. 
    
    Ok, now I just compiled Apache BlazeDS 4 from source, and I have no idea on what to do.
There are no .WAR files, and I'm not sure how to get started with any examples on Tomcat.
    
    So, I want to get things running on Tomcat, but I have no idea what to do next. Any help
would be appreciated.
    
    Thanks,
    
    Bruce

Mime
View raw message