flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mark goldin <markzolo...@gmail.com>
Subject Re: Application starts but then shows black screen
Date Tue, 01 Nov 2016 18:21:58 GMT
Yes, I understand that and I thought my code is working in a way to handle
async processes.
PreloadImages() is called for the first time and then it's called again
from PreloadImage_CompleteHandler when a download is complete. Is that is
not a case?

On Tue, Nov 1, 2016 at 1:14 PM OK <post@olafkrueger.net> wrote:

> Hi,
> I've not taken a deep look at you code but it seems to me that this is a
> async issue:
>
> If your inhouse network is fast enough maybe your http calls will handled
> in
> a synchronous fashion without any problems, but that's just accidentally.
> Keep in mind that http calls are asynchronous.
> If your first http request is not completely handled and you create the
> next
> one by just replacing the first URLRequest instance by a new URLRequest
> instance, the first one will probably fail.
>
> So maybe you have to take care to process your http requests one by one
> (Start the next call not before the previous is completely handled) or you
> could create several instances of URLRequest and handle each result by its
> particular URLRequest instance.
>
> I hope I could explain what I wanted to say...
>
> Olaf
>
>
>
>
>
> --
> View this message in context:
> http://apache-flex-users.2333346.n4.nabble.com/Application-starts-but-then-shows-black-screen-tp13991p13995.html
> Sent from the Apache Flex Users mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message