flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Harui <aha...@adobe.com>
Subject Re: DataGrid in 4.10.0 is blank
Date Sat, 27 Aug 2016 05:18:16 GMT
Can you post the skin?

On 8/26/16, 6:09 PM, "Kyle McKnight" <kamcknig@gmail.com> wrote:

>I also found this which looked promising
>http://apache-flex-development.2333347.n4.nabble.com/4-10-spark-datagrid-t
>d30705.html
>
>because this is using a custome skin but I removed the custom skin and it
>still did the same thing :(
>
>
>Kyle McKnight
>Senior UI Engineer - Accesso
>602.515.1444 (M)
>
>On Fri, Aug 26, 2016 at 8:56 PM, Kyle McKnight <kamcknig@gmail.com> wrote:
>
>> I'm not sure how to verify it honestly. Nothing in my code changed. So
>>I'm
>> not sure what new "requirements" the 4.10 over the 4.9.1 DataGrid might
>> need.
>>
>> I found this article mentioning basically the same thing except mine
>>only
>> has a horizontal scroll bar and not a veritcal
>>
>> http://mail-archives.apache.org/mod_mbox/flex-dev/201310.
>> mbox/%3C52568DFE.2090509@leeburrows.com%3E
>>
>>
>> Kyle McKnight
>> Senior UI Engineer - Accesso
>> 602.515.1444 (M)
>>
>> On Fri, Aug 26, 2016 at 1:55 PM, Alex Harui <aharui@adobe.com> wrote:
>>
>>> The stack trace indicates that centerGridColumnHeaderView is null.
>>>
>>> Can you verify that?  Then we can figure out what caused that.
>>>
>>> -Alex
>>>
>>> On 8/26/16, 6:42 AM, "Kyle McKnight" <kamcknig@gmail.com> wrote:
>>>
>>> >Offff course it works fine in my test of it by itself.
>>> >
>>> >
>>> >Kyle McKnight
>>> >Senior UI Engineer - Accesso
>>> >602.515.1444 (M)
>>> >
>>> >On Fri, Aug 26, 2016 at 9:26 AM, Kyle McKnight <kamcknig@gmail.com>
>>> wrote:
>>> >
>>> >> Yes it does, from 4.10.0 up to 4.15.0. I'll try to recreate what is
>>> >> happening in a standalone app, and send a link if I can recreate it
>>>but
>>> >> it'll be hard since there are so many moving parts.
>>> >>
>>> >>
>>> >> Kyle McKnight
>>> >> Senior UI Engineer - Accesso
>>> >> 602.515.1444 (M)
>>> >>
>>> >> On Fri, Aug 26, 2016 at 9:21 AM, Tom Chiverton <tc@extravision.com>
>>> >>wrote:
>>> >>
>>> >>> Sorry, I forgot to ask if it replicates in the the latest SDK ?
>>> >>>
>>> >>> Tom
>>> >>>
>>> >>>
>>> >>>
>>> >>> On 26/08/16 14:06, Kyle McKnight wrote:
>>> >>>
>>> >>>> Hi,
>>> >>>>
>>> >>>> This is an AIR project and am running it in debug mode. There
are
>>>no
>>> >>>> errors
>>> >>>> when the DataGrid is created. As for the stack trace on the
click
>>>it
>>> >>>>only
>>> >>>> happens if I click on a scroll bar on the DataGrid.
>>> >>>>
>>> >>>> spark.components::GridColumnHeaderGroup/grid_propertyChangeHandler
>>> at
>>> >>>> /Users/justinmclean/Documents/ApacheFlex4.10/frameworks/proj
>>> >>>> ects/spark/src/spark/components/GridColumnHeaderGroup.as:501
>>> >>>> flash.events::EventDispatcher/dispatchEventFunction
>>> >>>> flash.events::EventDispatcher/dispatchEvent
>>> >>>> mx.core::UIComponent/dispatchEvent at
>>> >>>> /Users/justinmclean/Documents/ApacheFlex4.10/frameworks/proj
>>> >>>> ects/framework/src/mx/core/UIComponent.as:13412
>>> >>>> spark.components::Grid/set horizontalScrollPosition
>>> >>>> spark.components::HScrollBar/setValue at
>>> >>>> /Users/justinmclean/Documents/ApacheFlex4.10/frameworks/proj
>>> >>>> ects/spark/src/spark/components/HScrollBar.as:353
>>> >>>> spark.components.supportClasses::ScrollBarBase/system_
>>> mouseMoveHandler
>>> >>>> at
>>> >>>> /Users/justinmclean/Documents/ApacheFlex4.10/frameworks/proj
>>> >>>> 
>>>ects/spark/src/spark/components/supportClasses/ScrollBarBase.as:810
>>> >>>>
>>> >>>>
>>> >>>>
>>> >>>> Kyle McKnight
>>> >>>> Senior UI Engineer - Accesso
>>> >>>> 602.515.1444 (M)
>>> >>>>
>>> >>>> On Fri, Aug 26, 2016 at 9:01 AM, Tom Chiverton
>>><tc@extravision.com>
>>> >>>> wrote:
>>> >>>>
>>> >>>> Please post the full stack trace (you may need to use the debug
>>> >>>>version
>>> >>>>> of
>>> >>>>> the Flash player).
>>> >>>>>
>>> >>>>> Tom
>>> >>>>>
>>> >>>>>
>>> >>>>>
>>> >>>>> On 26/08/16 13:51, Kyle McKnight wrote:
>>> >>>>>
>>> >>>>> sure I don't miss anything. But all of my DataGrids are
now blank
>>> and
>>> >>>>>> throw
>>> >>>>>> a type error of 1009 when clicked on. I'm not sure how
to fix it
>>> >>>>>>going
>>> >>>>>> from
>>> >>>>>> 4.9.1 to 4.10.0
>>> >>>>>>
>>> >>>>>>
>>> >>>>>
>>> >>>> ____________________________________________________________
>>> __________
>>> >>>> This email has been scanned by the Symantec Email Security.cloud
>>> >>>>service.
>>> >>>> For more information please visit http://www.symanteccloud.com
>>> >>>> ____________________________________________________________
>>> __________
>>> >>>>
>>> >>>
>>> >>>
>>> >>
>>>
>>>
>>

Mime
View raw message