flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Harbs <harbs.li...@gmail.com>
Subject Re: Embedded fonts still shown in iOS app, but disappeared in Android app
Date Tue, 26 Jul 2016 13:16:29 GMT
I think the first step is to confirm that it’s a Flex problem and not an AIR problem.

What happens if you compile the app using an older version of the Framework? Can you reproduce
the problem using the emulator, or does this only happen on physical devices?

Harbs

On Jul 26, 2016, at 3:47 PM, Alexander Farber <alexander.farber@gmail.com> wrote:

> Good afternoon!
> 
> There is a card game written in Apache Flex, which I am trying to keep
> alive and while the iOS version still works ok, the Android app has
> developed several visual problems over the last 1-2 years:
> 
> 1. The card suit symbols are not displayed correctly (my main problem!)
> 2. The ActionBar text color is black
> 3. The BusyIndicator stopped rotating
> 
> Here is my entire CSS file:
> 
> @namespace s "library://ns.adobe.com/flex/spark";
> @namespace mx "library://ns.adobe.com/flex/mx";
> 
> s|ActionBar {
>    chromeColor: #0066CC;
>    color: #FFFFFF;   /* BUT WHY IS IT BLACK SOMETIMES? */
>    titleAlign: center;
>    textShadowColor: #000000;
>    fontFamily: embFont;
> }
> 
> @font-face {
>    src: url("/assets/fonts/arial.ttf");
>    fontFamily: embFont;
>    embedAsCFF: false; /* required for StyleableTextField */
>    unicodeRange:
>        U+0020-U+0040, /* Punctuation, Numbers */
>        U+2660-U+2666, /* Card suits - BUT THEY STOPPED WORKING */
>        U+0041-U+005A, /* Upper-Case A-Z */
>        U+0061-U+007A, /* Lower-Case a-z */
>        U+0410-U+0451; /* Cyrillic */
> }
> 
> s|LabelItemRenderer {
>    fontFamily: embFont;
> }
> 
> And here is an MXML code excerpt showing the callout with card suits and
> the "dead" busy indicator:
> <s:titleContent>
>    <s:Label id="_titleTxt"
>             fontWeight="bold"
>             color="#FFFFFF"
>             width="100%" />
> 
>    <s:BusyIndicator id="_busy"
>                     includeInLayout="false"
>                     visible="false" />
> </s:titleContent>
> 
> <s:actionContent>
>    <s:CalloutButton id="_leftBtn"
>                     icon="{VIP}"
>                     verticalPosition="after"
>                     includeInLayout="false"
>                     visible="false">
>        <s:VGroup
>            width="100%">
>            <s:Label id="_left0" fontSize="{Preferans.FONT_SIZE}" />
> 
>            <s:Label id="_left1" fontSize="{Preferans.FONT_SIZE}"
> color="#FF0000" />
>            <s:Label id="_left2" fontSize="{Preferans.FONT_SIZE}" />
> 
>            <s:Label id="_left3" fontSize="{Preferans.FONT_SIZE}"
> color="#FF0000" />
>        </s:VGroup>
>    </s:CalloutButton>
> ...
> </s:actionContent>
> 
> Adding the following CSS code does not help:
> 
> s|LabelItemRenderer {
>    fontFamily: embFont;
> }
> 
> Also I keep installing and recompiling my app in Flash Builder 4.7 with
> every new Apache Flex release and make sure, that I don't forget to install
> the optional flex-fontkit.jar but that does not help.
> 
> Finally here are the screenshot demonstrating my problem:
> 
> http://stackoverflow.com/questions/38590070/embedded-fonts-still-shown-in-ios-app-but-disappeared-in-android-app
> 
> Thank you for any hints
> Alex


Mime
View raw message