flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From santanu4ver <santanu4...@gmail.com>
Subject Re: Apache Flex SDK installer problem
Date Fri, 24 Jun 2016 05:47:45 GMT
Alex Harui wrote
> The Installer is in the flex-utilities repo in the flex-installer folder.

We downloaded the sources for 3.2 from flex-utilities repo, and setup the
project in Flash Builder and ran. It ran well. We were required to download
following API separately as we couldn't found them in Apache source repo:

*com.probertson.utils.** inside ant_on_air/src
*de.ketzler.utils.** inside ant_on_air/src

For this test we choose Apache Flex SDK 4.13.0 with AIR SDK 20.0.

We're mostly on Yosemite. When we run the project we stuck on #4 dot.
Following is our error log:


> Using Locale: en_US
> Fetched the SDK download mirror URL from the CGI.
> SDK version Apache Flex SDK 4.13.0 
> AIR version 20.0
> Flash Player version 20.0
> Creating Apache Flex home
> Creating temporary directory
> Downloading Apache Flex SDK from:
> http://archive.apache.org/dist/flex/4.13.0/binaries/apache-flex-sdk-4.13.0-bin.tar.gz
> Verifying Apache Flex SDK MD5 Signature
> The Apache Flex SDK MD5 Signature of the downloaded files matches the
> reference.The file is valid.
> Uncompressing:
> /Users/xx/SDKs/apache-flex-sdk-4.1.13/temp/apache-flex-sdk-4.13.0-bin.tar.gz
> Finished uncompressing:
> /Users/xx/SDKs/apache-flex-sdk-4.1.13/temp/apache-flex-sdk-4.13.0-bin.tar.gz
> 
> Error #1034 
> TypeError: Error #1034 
> at org.apache.flex.xml::XMLTagProcessor/processChildren() 
> at org.apache.flex.ant.tags.supportClasses::TaskHandler/execute()
> at org.apache.flex.ant.tags::Project/execute()
> at org.apache.flex.ant::Ant/processXMLFile()
> at InstallApacheFlex/runInstallerScript()
> at InstallApacheFlex/handleApacheFlexSDKZipFileUnzipComplete()

When I debug through /processChildren()/ method in */XMLTagProcessor/*, I
found that /parentTag/ is a */Project/* class but not */ITextTagHandler/*
and following type casting throws the error:


> if (kind == "text")
> {
>       ITextTagHandler(parentTag).setText(xmlList[i].toString());
> }

If I try to bypass by a conditional check, this anyway creates other
unexpected behavior. 

My fellow colleague reports another error from /processXMLTag()/ method in
same class when she tried to run by the project, though. Her reports as
follows:


> Error: no processor for property
>  at
> org.apache.flex.xml::XMLTagProcessor/processXMLTag()[/Users/xx/Documents/Moonshine_Projects/MoonshineMultiCodeBase/ApacheFlexSDKInstaller/apache-flex-sdk-installer-3.2.0-src/ant_on_air/src/org/apache/flex/xml/XMLTagProcessor.as:50]
>  at
> org.apache.flex.xml::XMLTagProcessor/processChildren()[/Users/xx/Documents/Moonshine_Projects/MoonshineMultiCodeBase/ApacheFlexSDKInstaller/apache-flex-sdk-installer-3.2.0-src/ant_on_air/src/org/apache/flex/xml/XMLTagProcessor.as:77]
>  at
> org.apache.flex.ant.tags.supportClasses::TaskHandler/execute()[/Users/xx/Documents/Moonshine_Projects/MoonshineMultiCodeBase/ApacheFlexSDKInstaller/apache-flex-sdk-installer-3.2.0-src/ant_on_air/src/org/apache/flex/ant/tags/supportClasses/TaskHandler.as:53]
>  at
> org.apache.flex.ant.tags::Project/execute()[/Users/xx/Documents/Moonshine_Projects/MoonshineMultiCodeBase/ApacheFlexSDKInstaller/apache-flex-sdk-installer-3.2.0-src/ant_on_air/src/org/apache/flex/ant/tags/Project.as:112]
>  at
> org.apache.flex.ant::Ant/processXMLFile()[/Users/xx/Documents/Moonshine_Projects/MoonshineMultiCodeBase/ApacheFlexSDKInstaller/apache-flex-sdk-installer-3.2.0-src/ant_on_air/src/org/apache/flex/ant/Ant.as:90]
>  at
> InstallApacheFlex/runInstallerScript()[/Users/xx/Documents/Moonshine_Projects/ApacheFlexSDKInstaller/InstallApacheFlex/src/InstallApacheFlex.mxml:1940]
>  at
> InstallApacheFlex/handleApacheFlexSDKZipFileUnzipComplete()[/Users/xx/Documents/Moonshine_Projects/ApacheFlexSDKInstaller/InstallApacheFlex/src/InstallApacheFlex.mxml:1843]

Now, the funny thing is when we tried to download the same SDK by standalone
installer (one that distributing by Apache site) we succeed! So what
possibly is different between the distributing package and it's source file?
Any idea?



--
View this message in context: http://apache-flex-users.2333346.n4.nabble.com/Apache-Flex-SDK-installer-problem-tp12405p12929.html
Sent from the Apache Flex Users mailing list archive at Nabble.com.

Mime
View raw message