flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Harui <aha...@adobe.com>
Subject Re: Flatspark - Issues with ButtonIcon component on a mobile device
Date Thu, 10 Mar 2016 21:30:15 GMT
I think there may be subtle differences in the styles for Button between
desktop and mobile themes, such has fontWeight="bold" or using TextField
instead of TextLine so the embedded font lookup will fail.

-Alex

On 3/10/16, 10:19 AM, "Sugan Naicker" <Sugan@dev-x.co.za> wrote:

>Hi Olaf,
>
>Thanks for the feedback and the time and effort to reproduce the error.
>
>I am getting the same results. On Desktop works fine, but on mobile
>project
>it does not.
>
>Rgs,
>
>Sugan
>
>-----Original Message-----
>From: OK [mailto:OKrueger@edscha.com]
>Sent: Thursday, March 10, 2016 4:54 PM
>To: users@flex.apache.org
>Subject: Re: Flatspark - Issues with ButtonIcon component on a mobile
>device
>
>I'd only like to tell you that I can reproduce this issue:
>I've created a Flex Mobile project within the flatspark button icon
>inside. 
>Instead of the icon a cross is displayed. (Using the AIR Simulator).
>I've played a bit with a custom ButtonIconSkin without any success :-( It
>seems that the iconFont is not applied...
>
>The Label standalone is working (The ButtonIconSkin uses a Label to
>display
>the icon):
><s:Label fontFamily="FontAwesome" text="{AwesomeUtils.fa_info_circle}" />
>
>With a desktop project it all works like a charme.
>
>?
>
>Olaf
>
>
>
>--
>View this message in context:
>http://apache-flex-users.2333346.n4.nabble.com/Flatspark-Issues-with-Butto
>nI
>con-component-on-a-mobile-device-tp12173p12178.html
>Sent from the Apache Flex Users mailing list archive at Nabble.com.
>
>

Mime
View raw message