flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Chiverton ...@extravision.com>
Subject Re: Flex 4.15 on Linux - no flex-config.xml created
Date Mon, 14 Mar 2016 15:04:42 GMT
Nothing reported as going wrong. The below is from the initial install, 
and looks identical to when I ran some other targets by hand (see my 
second post that may have crossed with this one)

I don't see any reference to "create-config:" in the installer output, 
which might be the issue ?

================================
put-in-cache:
       [get] Getting: 
http://flex.apache.org/installer/properties/sdk/en_US.properties
       [get] To: 
/home/tchiverton/workspace/apache-flex-sdk-4.15.0-bin/en_US.properties

copy-if-cached:
      [copy] Copying 1 file to 
/home/tchiverton/workspace/apache-flex-sdk-4.15.0-bin/lib/external/optional

get-third-party-files:

flex-sdk-description-flash:

flex-sdk-description-air:

fixup-config-files:
      [echo] Installing frameworks configuration files configured for 
use with an IDE
       [get] Getting: 
http://flex.apache.org/installer/properties/sdk/en_US.properties
       [get] To: 
/home/tchiverton/workspace/apache-flex-sdk-4.15.0-bin/en_US.properties

fixup-config-files-version:
       [get] Getting: 
http://flex.apache.org/installer/properties/sdk/en_US.properties
       [get] To: 
/home/tchiverton/workspace/apache-flex-sdk-4.15.0-bin/en_US.properties

fixup-config-files-swfversion:
      [copy] Copying 1 file to 
/home/tchiverton/workspace/apache-flex-sdk-4.15.0-bin/ide/flashbuilder/config
      [copy] Copying 1 file to 
/home/tchiverton/workspace/apache-flex-sdk-4.15.0-bin/ide/flashbuilder/config
      [copy] Copying 1 file to 
/home/tchiverton/workspace/apache-flex-sdk-4.15.0-bin/ide/flashbuilder/config

install:
    [delete] Deleting directory 
/home/tchiverton/workspace/apache-flex-sdk-4.15.0-bin/in
      [echo] /home/tchiverton/workspace/apache-flex-sdk-4.15.0-bin is 
now an IDE compatible folder

BUILD SUCCESSFUL

===============================

On 14/03/16 14:51, Alex Harui wrote:
> Hi Tom,
>
> I'm not sure how well the installer likes starting at different 
> targets, so run the whole install again and see what the log says in 
> fixup-config-files.
>
> -Alex
>
> From: Tom Chiverton <tc@extravision.com <mailto:tc@extravision.com>>
> Reply-To: "users@flex.apache.org <mailto:users@flex.apache.org>" 
> <users@flex.apache.org <mailto:users@flex.apache.org>>
> Date: Monday, March 14, 2016 at 3:37 AM
> To: "users@flex.apache.org <mailto:users@flex.apache.org>" 
> <users@flex.apache.org <mailto:users@flex.apache.org>>
> Subject: Flex 4.15 on Linux - no flex-config.xml created
>
> I'm having trouble having followed the Ant-based install at
> https://cwiki.apache.org/confluence/display/FLEX/Installation+help
> for 4.15.
>
> mxmlc says
> defaults: Error: unable to open 
> '/home/tchiverton/workspace/apache-flex-sdk-4.15.0-bin/frameworks/flex-config.xml'
>
> and this file is missing, even though Ant reported success.
>
> I looked through installer.xml, but
> ant -f installer.xml -Dair.sdk.version=2.6 fixup-config-files
>
> reports
> Buildfile: 
> /home/tchiverton/workspace/apache-flex-sdk-4.15.0-bin/installer.xml
>       [get] Getting: 
> http://flex.apache.org/installer/properties/sdk/en_US.properties
>       [get] To: 
> /home/tchiverton/workspace/apache-flex-sdk-4.15.0-bin/en_US.properties
>
> flex-sdk-description-flash:
>
> flex-sdk-description-air:
>
> fixup-config-files:
>      [echo] Installing frameworks configuration files configured for 
> use with an IDE
>       [get] Getting: 
> http://flex.apache.org/installer/properties/sdk/en_US.properties
>       [get] To: 
> /home/tchiverton/workspace/apache-flex-sdk-4.15.0-bin/en_US.properties
>
> fixup-config-files-version:
>       [get] Getting: 
> http://flex.apache.org/installer/properties/sdk/en_US.properties
>       [get] To: 
> /home/tchiverton/workspace/apache-flex-sdk-4.15.0-bin/en_US.properties
>
> fixup-config-files-swfversion:
>
> BUILD FAILED
> /home/tchiverton/workspace/apache-flex-sdk-4.15.0-bin/installer.xml:780: 
> Replace: source file 
> /home/tchiverton/workspace/apache-flex-sdk-4.15.0-bin/frameworks/flex-config.xml 
> doesn't exist
>
> so that can't be the right target to fix it.
>
> Any Ant gurus know what might be up ?
> -- 
> *Tom Chiverton*
> Lead Developer
> e: 	tc@extravision.com
> p: 	0161 817 2922
> t: 	@extravision <http://www.twitter.com/extravision>
> w: 	www.extravision.com
>
> Extravision - email worth seeing <http://www.extravision.com/>
> Registered in the UK at: 107 Timber Wharf, 33 Worsley Street, 
> Manchester, M15 4LD.
> Company Reg No: 0‌‌5017214 VAT: GB 8‌‌24 5386 19
>
> This e-mail is intended solely for the person to whom it is addressed 
> and may contain confidential or privileged information.
> Any views or opinions presented in this e-mail are solely of the 
> author and do not necessarily represent those of Extravision Ltd.
>
>
> ______________________________________________________________________
> This email has been scanned by the Symantec Email Security.cloud service.
> For more information please visit http://www.symanteccloud.com
> ______________________________________________________________________


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message