flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Chiverton ...@extravision.com>
Subject Re: Flex 4.15 on Linux - no flex-config.xml created
Date Mon, 14 Mar 2016 14:57:43 GMT
  ant -f build.xml create-config
has created the files, but they haven't had the build numbers etc 
substituted in. Running
  ant -f installer.xml -Dair.sdk.version=2.6 fixup-config-files
appears to do that.

Is something missing in the installer.xml ?

Tom

On 14/03/16 11:37, Tom Chiverton wrote:
> I'm having trouble having followed the Ant-based install at
> https://cwiki.apache.org/confluence/display/FLEX/Installation+help
> for 4.15.
>
> mxmlc says
> defaults: Error: unable to open 
> '/home/tchiverton/workspace/apache-flex-sdk-4.15.0-bin/frameworks/flex-config.xml'
>
> and this file is missing, even though Ant reported success.
>
> I looked through installer.xml, but
> ant -f installer.xml -Dair.sdk.version=2.6 fixup-config-files
>
> reports
> Buildfile: 
> /home/tchiverton/workspace/apache-flex-sdk-4.15.0-bin/installer.xml
>       [get] Getting: 
> http://flex.apache.org/installer/properties/sdk/en_US.properties
>       [get] To: 
> /home/tchiverton/workspace/apache-flex-sdk-4.15.0-bin/en_US.properties
>
> flex-sdk-description-flash:
>
> flex-sdk-description-air:
>
> fixup-config-files:
>      [echo] Installing frameworks configuration files configured for 
> use with an IDE
>       [get] Getting: 
> http://flex.apache.org/installer/properties/sdk/en_US.properties
>       [get] To: 
> /home/tchiverton/workspace/apache-flex-sdk-4.15.0-bin/en_US.properties
>
> fixup-config-files-version:
>       [get] Getting: 
> http://flex.apache.org/installer/properties/sdk/en_US.properties
>       [get] To: 
> /home/tchiverton/workspace/apache-flex-sdk-4.15.0-bin/en_US.properties
>
> fixup-config-files-swfversion:
>
> BUILD FAILED
> /home/tchiverton/workspace/apache-flex-sdk-4.15.0-bin/installer.xml:780: 
> Replace: source file 
> /home/tchiverton/workspace/apache-flex-sdk-4.15.0-bin/frameworks/flex-config.xml 
> doesn't exist
>
> so that can't be the right target to fix it.
>
> Any Ant gurus know what might be up ?
> -- 
> *Tom Chiverton*
> Lead Developer
> e: 	tc@extravision.com
> p: 	0161 817 2922
> t: 	@extravision <http://www.twitter.com/extravision>
> w: 	www.extravision.com
>
> Extravision - email worth seeing <http://www.extravision.com/>
> Registered in the UK at: 107 Timber Wharf, 33 Worsley Street, 
> Manchester, M15 4LD.
> Company Reg No: 0‌‌5017214 VAT: GB 8‌‌24 5386 19
>
> This e-mail is intended solely for the person to whom it is addressed 
> and may contain confidential or privileged information.
> Any views or opinions presented in this e-mail are solely of the 
> author and do not necessarily represent those of Extravision Ltd.
>


Mime
View raw message