flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Philip Keiter <philip.kei...@gmail.com>
Subject Re: Flex-sdk on linux
Date Tue, 22 Dec 2015 16:50:59 GMT
I found that localization/globalization does not work when building on
Linux.

-Philip

On Tue, Dec 22, 2015 at 8:06 AM, Andrew Kerr <akerr@fluid.com> wrote:

> It *is* possible to run FlexUnit tests on Linux (or at least on Ubuntu
> 14.04, where I managed to get it working).  See
> https://github.com/ajkerr/chef-flashprojector.
>
> On Tue, Dec 22, 2015 at 8:15 AM, Christofer Dutz
> <christofer.dutz@c-ware.de> wrote:
> >
> > We also build Flex applications on Linux ... the only thing you actually
> can't do is have FlexUnit tests run in the Flashplayer or using The Air
> Debug Launcher ...
> >
> > Chris
> >
> > ________________________________________
> > Von: Tom Chiverton <tc@extravision.com>
> > Gesendet: Dienstag, 22. Dezember 2015 13:39
> > An: users@flex.apache.org
> > Betreff: Re: Flex-sdk on linux
> >
> > If all you want to do is build a project that uses Apache Flex, then you
> > can use the binary distribution of the Apache Flex SDK :
> > http://flex.apache.org/download-binaries.html
> > and the ant (a Java based tool) install method :
> >
> https://cwiki.apache.org/confluence/display/FLEX/Installation+help#Installationhelp-Ant-basedinstaller
> > which does not need the AIR based installer. No need to be an ant guru !
> >
> > This will get you a functioning Apache Flex SDK on Linux.
> >
> > It would be interesting to see how you get on with Scratch.
> >
> > Tom
> >
> > On 22/12/15 12:07, dustfinger@starbucksoftware.com wrote:
> >> Hi,
> >>
> >> I am new to the mailing list. I have read in the archives that there was
> >> some effort to imporove support for linux. I know that the main mark on
> >> using flex-sdk on linux is that it depends on Adobe Air which has not
> >> been supported for linux since version 2.6. The following thread makes
> >> it seem like there isn't a direct dependency on Adobe Air and there was
> >> talk about how to remove the dependency:
> >>
> http://apache-flex-users.2333346.n4.nabble.com/Flex-SDK-on-Linux-tc881.html#none
> >>
> >> My ultimate goal is to build MIT scratch 2.0 for linux which depends on
> >> flex. My preference is to build this all from source because I am trying
> >> to write an ebuild for the gentoo linux distribution for scratch 2.0 and
> >> dependencies.
> >>
> >> I should note that I have never used ant. I am not a java developer, but
> >> I am capable of learning what I need to know.
> >>
> >> Thank you for your time in advance.
> >>
> >> Sincerely,
> >>
> >> Trevor Wilson
> >>
> >> ______________________________________________________________________
> >> This email has been scanned by the Symantec Email Security.cloud
> service.
> >> For more information please visit http://www.symanteccloud.com
> >> ______________________________________________________________________
> >>
> >
>
>
>
> --
> Andrew Kerr
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message