flex-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Scott Matheson <sc...@matheson.it>
Subject Re: Asset loading
Date Wed, 09 Dec 2015 18:12:19 GMT
Sorry when we can not get the asset off our site, the URL load fails on the instance of the
effect we would replace the sound we are trying to download with a emended MP3 of 1 sec of
nothing (white space)  this way the effect has something to play 

Sent from my iPhone

> On 9 Dec 2015, at 17:33, Alex Harui <aharui@adobe.com> wrote:
> 
> I don't understand what you mean by "white space".  Maybe a code snippet
> will help.
> 
>> On 12/9/15, 7:21 AM, "Scott Matheson" <scott@matheson.it> wrote:
>> 
>> Hi
>>  We are having some issues loading assets in schools with poor
>> internet, or with the firewalls killing connections, anyway we believe
>> our only solution is to subclass “something” not sure what we need tio
>> subclass, has any one tried this or can give us any hints so we  can add
>> business logic that will retry to load the asset or replace the asset
>> with an embedded file
>> 
>> 
>> This is the issue we have --------------
>> 
>> When the url fails to load the custom effect replaces its own source
>> property with white space (embedded files) successfully. However the
>> "sound effect instance" has already been created and has not got a valid
>> sound so errors when attempting to play.
>> 
>> At what time during the event/eventinstance  life-cycle is it good to
>> fall back and replace with white space?
>> 
>> Is there a way to modify the effect instance after the init instance has
>> been called? i.e. when the sound actually loads.
> 

Mime
View raw message